WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
Plugin Activation raises fatal error (3 posts)

  1. rjebamalaidass
    Member
    Posted 1 year ago #

    Hi,
    Currently I am using WordPress Https 3.1.2 in a wordpress multisite environment. When I try to upgrade and network activate the plugin, I am getting the following error message.
    "Plugin could not be activated because it triggered a fatal error"

    When I checked the logs, I am getting the following error.

    PHP Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 64 bytes) in /blogs/wp-includes/meta.php on line 571, referer: http://xxx.xxx.xxx/wp-admin/network/plugins.php?error=true&plugin=wordpress-https%2Fwordpress-https.php&_error_nonce=5c98d99456

    I tried increasing the memory to 1GB, but still the same issue happens and gives error message as 1GB exhausted.
    But when I removed this plugin and tried activating other required plugin, other plugins are getting activated properly without any issues.

    I am in wordpress 3.4.2. Kindly help me as I am clueless here.

    With Regards
    Rejoice Raja Jebamalaidass

    http://wordpress.org/extend/plugins/wordpress-https/

  2. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    I'm guessing you have quite a few multisites? I need to optimize the installation for sites that have a lot of sites. The plugin is running the install process for each site and that (apparently) eats up a lot of RAM. I'll see what I can do about it in the release I'm going to push out later today to fix other issues with 3.3.5.

  3. rjebamalaidass
    Member
    Posted 1 year ago #

    You are correct. I have 59 Sites running in my Blog. Totally around 2300 users added to my blog.
    At present, I am using WordPress HTTPS 3.1.2 and I am getting the following issues. I think the 3.1.2 version is not compatible to WordPress 3.4.2. That is the reason why I thought of upgrading it to the new version.

    PHP Warning: Missing argument 5 for WordPressHTTPS_Module_Filters::get_avatar() in /srv/www/htdocs/blogs/wp-content/plugins/wordpress-https_oldVersion/lib/WordPressHTTPS/Module/Filters.php on line 117

    When I try to edit the image while posting, I am not able to align the image as the pop up is completely blank. When I disable the WordPress HTTPS, I am able to align the image.

    If we can solve the memory issue, then it would be great for me as it would solve this long pending issue

    Thanks for your contribution in this plugin.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic