WordPress.org

Ready to get started?Download WordPress

Forums

Achievements for WordPress
[Plugin: Achievements for BuddyPress] Unlocked 42 years, 3 months ago ago even if they haven't! (6 posts)

  1. NickMackz
    Member
    Posted 2 years ago #

    I am using the custom community theme and on the Unlocked By list for an achievement it lists most but not all members, whether or not they have unlocked the achievement. It also shows everyone as having unlocked it Unlocked 42 years, 3 months ago ago. This is the same for all achievements.

    I noticed that this list is provided by members-loop.php by your plugin does not contain this so I assume it must be using the one from my theme?

    Any suggestions on how to fix this?

    http://wordpress.org/extend/plugins/achievements/

  2. NickMackz
    Member
    Posted 2 years ago #

    It works on the default buddy press theme but I haven't been able to work out yet what is missing / wrong in custom community.

  3. NickMackz
    Member
    Posted 2 years ago #

    Tracked it down to something in my child theme. Any suggestions on what it may be? The main part of my child theme customises bbpress.

  4. NickMackz
    Member
    Posted 2 years ago #

    Done a bit more testing. It works on the parent theme, but not on an entirely empty child theme (nothing but style.css) so it would appear that the child theme is missing something required?

  5. NickMackz
    Member
    Posted 2 years ago #

    Managed to a hack a fix by commenting these lines from achievements-filters.php in the plugin includes folder:

    if ( isset( $sql_parts['select_main'] ) )
    remove_filter( 'bp_core_get_paged_users_sql', 'dpa_filter_users_by_achievement', 10, 2 );
    else
    remove_filter( 'bp_core_get_total_users_sql', 'dpa_filter_users_by_achievement', 10, 2 );

    Does anyone have any idea why this would fix the issue?

    Is this 'fix' likely to have any knock on effects?

  6. Paul Gibbs
    BuddyPress Lead Developer
    Plugin Author

    Posted 2 years ago #

    I don't know why this problem would have occurred, or why removing that particular filter would have fixed things. I'm going to assume the CC theme filters something that BuddyPress does too, and that they conflict. I'll try to reach out to the people who make CC at some point.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic