WordPress.org

Ready to get started?Download WordPress

Forums

Plug-in Search Error: An unexpected error occurred. Something may be wrong wit.. (4 posts)

  1. TeraBrite
    Member
    Posted 1 year ago #

    When I go to search for a plug-in in the dashboard for my website http://TeraBrite.tv I get the following error: "An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums." I'm also getting other errors in certain plug-ins, please read on to fully understand my issue!

    I'm not sure what is causing this, however everything was working just fine this morning and I did just go through all kinds of crap with two plug-ins (W3 Total Cache and Bullet Proof Security) on the phone with Host Gator in attempt to figure out how to fix it, didn't get very far, and now I'm getting this error. So there is definitely a chance we messed something up in the process but he sort of gave up on it and told me to contact the support forums.

    Here is what happened in detail: I was getting an error in W3 Total Cache that certain things weren't working due to the .htaccess file (I'm assuming these errors appeared after the update) and each error had an auto install option next to it. It looked something like this for each error except with other things like Minify and such: "Browser caching is not active. To enable it, add the following rules into the server configuration file (/blabla/blabla/blabla/.htaccess) of the site. Or if permission allow this can be done automatically, by clicking here: auto-install." I clicked them and it gave me an error and said that it didn't install successfully. I immediately assumed that Bullet Proof Security was denying access to the file to auto install so I followed the steps to de-activate BPS and then went and clicked the auto install and it worked. That's when my website stopped working entirely and was giving me a 500 internal server error so I called up Host Gator. Basically the Host Gator guy noticed strange ? in a box characters popping up in the .htaccess file and I'm not sure but I'm assuming he removed them and it got my website back up. However these characters kept popping up when i would go in and try things out to fix the errors in W3 Total Cache. We eventually ended up following the steps to completely remove Bullet Proof Security and I then clicked the auto install buttons again in W3 Total Cache that were popping up. It works, but after doing so I still have the following errors in W3 Total Cache:

    It appears Page Cache URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration.

    It appears Minify URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration.

    He suggested I install the code manually instead of Auto-Installing, the only problem is I didn't have those error messages that provided the code anymore. He then told me to delete and re-install W3 Total Cache, so I deleted it and when I went to Add New to search for the plug-in that's when I received this error:

    "An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums.

    Try again"

    I can no longer search for plug-ins on this website. The Host Gator guy seemed to think it had something to do with the WordPress servers or something but I checked and I can search without a problem on my other WordPress sites so he clearly was just trying to get off the phone with me because we had been on the phone for multiple hours. He then instructed me to use the WordPress forum as it said in the error.

    Anyway, after I got off the phone with him I manually downloaded W3 Total Cache and uploaded/installed it and I am seeing the same errors as before and now if I leave W3 Total Cache enabled for an extended period of time eventually my website loses all styles, everything is left aligned and all images are to scale single file down the entire page.

    So basically I need help with the search errors and the W3 Total Cache errors. I'm sorry this is a lot to ask, but someone has to be able to help me out here! I know little to none about code, and only really have experience with the dashboard so please be as specific as possible!

    I would also like to note that this website is using the Pro Plan of CloudFlare. Not sure if that makes a difference, but I might as well provide as much info as possible.

    Hopefully someone can help me! This is so annoying!

  2. DannyF247
    Member
    Posted 1 year ago #

    First, we need to get the 500 "Internal Server Error" fixed. Paste (or Pastebin) your htaccess file and post it here, and maybe we can help you :)

    (Love your music by the way, you both are so talented!)

  3. TeraBrite
    Member
    Posted 1 year ago #

    I would actually like to thank you DannyF247 for that comment, why? Because I had no idea my site was getting the 500 "Internal Server Error" again. Also, because of this I actually ended up fixing the problems myself!

    I went in and replaced the htaccess file with a backup I had created of it earlier to get the site back up and running. I then went in and deactivated all of my plugins and also installed reinstalled WordPress using the reinstall button. I didn't think that would really do too much, but turns out it fixed the searching issue. I then opened up W3 Total Cache and noticed I was still getting this error:

    "It appears Page Cache URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration."

    Just for fun, I decided to delete W3 Total Cache again and reinstall it, except this time using the search feature that wasn't working before.. after doing so the error was gone! I reactivated all of my plugins and the error came back. So I deactivated them again and did what anyone else would do, active them one by one and continue checking for the error. Found the plugin that was the culprit, it's a plugin that allows you to place extra required fields onto the registration page. No big deal, deleted it. Everything seems to be working now!

    Thanks for your concern!

  4. DannyF247
    Member
    Posted 1 year ago #

    Very glad the problem is solved! :)

Topic Closed

This topic has been closed to new replies.

About this Topic