Please can someone revise the Requirements page urgently:
Currently it only states the Minimum Requirements - which are PHP version 4.3
and MySQL version 4.1.2
Would it not be better to give the recommended requirements instead?
According to this statement from WordPress published six months ago:
- WordPress will soon be abandoning support for PHP 4 and MySQL 4.
I know the new versions haven't rolled out as quickly as this document predicted but it could be just a couple of months before version 3.2 comes out which will only work using PHP 5.2 or higher and MySQL 5.0.15 or higher.
Also, a lot of current plug ins only work with PHP 5 - so the version you suggest isn't even right for the time being.