WordPress.org

Ready to get started?Download WordPress

Forums

mqTranslate
[resolved] Please remove Max_Supported_WP! (9 posts)

  1. jondewitt
    Member
    Posted 6 months ago #

    WordPress is auto-updating now and every one of my sites that auto updated also had its translation automatically disabled even though the functionality wasn't affected at all. Please change how this functionality works or just remove it :(

    http://wordpress.org/plugins/mqtranslate/

  2. chsxf
    Member
    Plugin Author

    Posted 6 months ago #

    The plugin disables itself to avoid breaking the post and page editor but the localization features are still functional.
    The QT_*_SUPPORTED_WP_VERSION constants are a feature of the original qTranslate and we do not have any plan to remove it.

  3. jondewitt
    Member
    Posted 6 months ago #

    It's a bad feature. Editing a page or post after the plugin has disabled itself can lead to a single post housing all of the content for whatever languages you previously had separated. Thanks though I'll just keep editing the plugin file to change max supported version.

  4. leslierad
    Member
    Posted 3 months ago #

    @jondewitt

    If you are worried about WP auto updates you could always change
    /wp-content/plugins/mqtranslate/mqtranslate.php

    From:
    --- define('QT_MAX_SUPPORTED_WP_VERSION', '3.9');

    To:
    +++ define('QT_MAX_SUPPORTED_WP_VERSION', get_bloginfo('version'));

  5. chsxf
    Member
    Plugin Author

    Posted 3 months ago #

    We are looking to change our WordPress versions support.
    In a future update, we will change QT_MIN|MAX_SUPPORT_WP_VERSION to QT_MIN|MAX_SUPPORT_WP_MAJOR_RELEASE

    By supporting major releases, we will improve support between security patch releases of WordPress, which generally do not break the plugin.

  6. chsxf
    Member
    Plugin Author

    Posted 3 months ago #

    The next release will introduce the feature I told about in my previous post.

  7. Ismael Latorre
    Member
    Posted 3 months ago #

    Hi. I just updated to wp 3.9 and the plugin to its current latest version. It deactivated itself, giving me the "The mqTranslate Editor has disabled itself because it hasn't been tested with your WordPress version yet." message, event though both the wp and plugin versions are the latest. I tried by changing the QT_MAX_SUPPORTED_WP_VERSION parameter as explained above, but it is not working. Please, help.

  8. chsxf
    Member
    Plugin Author

    Posted 3 months ago #

    New version 2.6.2.1 fixes the blocking bug introduced in 2.6.2. Very sorry for the inconvenience.

  9. Ismael Latorre
    Member
    Posted 3 months ago #

    Fantastic. Many thanks.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.