WordPress.org

Ready to get started?Download WordPress

Forums

ProPlayer
Please include this fix for compatibility with WP-United (1 post)

  1. jhong
    Member
    Posted 1 year ago #

    Hi,

    Because proplayer requires WordPress core files directly using require_once, it is incompatible with my plugin, WP-United.

    WordPress isn't always bootstrapped through wp-config, so assuming that require_once will only bootstrap WordPress is WordPress is not already loaded is incorrect.

    To fix the problem, please wrap your call to require_once(... wp-config.php ...) in a check to see if ABSPATH is already defined, or if this is an AJAX call, use WordPress' AJAX API.

    Thanks!

    John

    More info here:

    http://www.wp-united.com/viewtopic.php?f=14&t=3323&p=14024#p14024

    http://wordpress.org/extend/plugins/proplayer/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.