WordPress.org

Ready to get started?Download WordPress

Forums

Please, I need help: Unable to post and setting not saved (8 posts)

  1. karbo
    Member
    Posted 8 years ago #

    I am trying again; i seriously need help here. I have upgraded to WP 2.0, and I can not post any blog entries.

    I have two users. I have tried with both. I write my blog entry and I press "Save", or "Publish", it doesnt matter; the post is not saved to the database and I am taken back to the post form, where the post is still in the form, and there is no status message.

    There is also a message below the form saying "This script was not meant to be called directly.". I don't know if that is connected to my problems.

    I am also experiencing problems when trying to modify settings; what ever changes I do, nothing is saved. EXCEPT when I change settings on the user profile page. I have unchecked the rich editor because i didnt like it. I was unable to do this from the configuration page, but when doing it individually for each user it works... So it seems it's nothing wrong with the DB connection if that is written to the database...

    Can anyone please help me out here?

    I am running PHP Version 5.0.4 and MySQL 4.0.24-standard.

    Thanks for any help. WordPress 1.5 rocked, I want 2.0 to work as well.

  2. moshu
    Member
    Posted 8 years ago #

    Did you try to upload a freshly downloaded version of the files? Could it be that some files got corrupted during the download/upload?
    If you just re-upload the files (keep the wp-config and .htaccess if you have) do not run install or upgrade, just replace the files and see if it works.

  3. karbo
    Member
    Posted 8 years ago #

    First time I followed the upgrade instructions to the last period. I tried a second time tonight, deleting the whole blog directory, uploading the new 2.0 files, then overwriting the wp-config file. And ran the upgrade script. The second time I did not download the files to my computer first, but the tar.gz directly to my site and unpacked there. It would be very strange that file corruption should happen both times, with different approaches and causing the exactly same problem...

  4. FlawlessKnockoff
    Member
    Posted 8 years ago #

    Karbo, I have the EXACT same problem and I have absolutely NO idea how to solve this.

    Help!

  5. FlawlessKnockoff
    Member
    Posted 8 years ago #

    UP... Are we the only two people having this problem?

  6. rammer
    Member
    Posted 8 years ago #

    nope. I get the same message having just done a clean install. I get this message from the login script. "This script was not meant to be called directly."

    about to re-ftp the login script, just in case.

  7. efrumnash
    Member
    Posted 8 years ago #

    Same problem for me PHP 5.0.4, MySQL 4.1x, Apache 2.x

    I've installed this on other linux servers with no problem but this particular host doesn't seem to be working.

    I'm also getting the referers need to be enabled error on this server but not on others.

  8. opengeek
    Member
    Posted 8 years ago #

    I am getting this error now after upgrading to 2.0.2, and moving the sites to a new server with PHP 5.0.4 as well. Is there a patch for this? Or can anyone identify the problem?

Topic Closed

This topic has been closed to new replies.

About this Topic