WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] PLEASE HELP![You don't have permission to access /index.php on this server.] (9 posts)

  1. leochu
    Member
    Posted 7 years ago #

    Hi all,

    My site got this problem today, but i havn't change anything to my code.

    if people refer from other site will got follow

    Forbidden
    You don't have permission to access /blog/index.php on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/1.3.33 Server at hexamax.com Port 80

    Like this:
    http://hexamax.com/blog/2006/10/28/panda-baby/

    but if they go to the page from my index page, that work well.
    http://hexamax.com/blog/

    I searched around and somewhere said "SecFilterInheritance Off"

    but there is no mod_security on my site...

    here is my phpinfo page, please help!!!!THANKS!!!
    http://hexamax.com/bine/blogphyte/phpinfo.php

  2. moshu
    Member
    Posted 7 years ago #

    but if they go to the page from my index page, that work well.
    http://hexamax.com/blog/

    No, it doesn't work. Forbidden, too.

  3. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    Check the permissions on the /blog/index.php file. Make sure it's at least 444.

  4. leochu
    Member
    Posted 7 years ago #

    hi Otto42,
    It is 666 all the time, my blog ran about 4 months, this problem started since yesterday....

    I think is something related to .htaccess trying to redirect to the Permalinks...

    Thanks!

  5. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    666 is a bad permission for files that you don't expect to have to modify. 444 would be better, or 644 at most. Could be a problem with your host, I'd ask them about it.

    As far as .htaccess goes, it should be redirecting *all* your blog traffic to the index.php file. That's what it does. The blog code itself figures out what the page to display is.

    What's in your .htaccess file?

  6. leochu
    Member
    Posted 7 years ago #

    The .htaccess just the one generated from Permalinks setting

  7. vkaryl
    Member
    Posted 7 years ago #

    If you changed nothing - no upgrade? no new plugin? no theme change? - then ask your host what they might have done backend.

  8. leochu
    Member
    Posted 7 years ago #

    I did something to fix the problem temporary.
    I changed my .htaccess and point my URL rewrite to a copy of index.php on public_html,
    but for long term, I still want my wordpress can contain in one directory.
    It seem I can't URL rewrite my request to a file which is under /public_html/blog/ since 30th Oct;
    wish I can change back my original setting soon.
    However, my host is suck that they still have no any responses :(

  9. vkaryl
    Member
    Posted 7 years ago #

    Ouch. I feel your pain.... maybe time for a new host?

Topic Closed

This topic has been closed to new replies.

About this Topic