WordPress.org

Ready to get started?Download WordPress

Forums

Please help with login theme trouble! (10 posts)

  1. PepperedSugar
    Member
    Posted 2 years ago #

    Everytime I log into my WP site I get the error below. This started a few days ago after I changed my theme and I can't seem to get it fixed. It only shows this, I can't even get back to anything to change it back or try to fix it. Here is the error:

    Fatal error: Cannot redeclare setting_pass_fn() (previously declared in /home/mystuff/public_html/wp-content/plugins/open-menu/openmenu.php:566) in /home/mystuff/public_html/wp-content/themes/zombie-apocalypse/zombie-admin-functions.php on line 559.

    I changed the original name here to "mystuff" but everything else is exactly as shown.

    I would really appreciate any help here, but please be descriptive with your answer. In other words, I am really new to WordPress and HTML and do not know where to go to fix this or how to get there! So a specific and detailed walkthrough with exactly what I need to do would be most helpful. Thank you to everyone in advance for any and all help you can provide for me.

  2. Caps
    Blocked
    Posted 2 years ago #

    FTP and rename the current theme folder. Log back in and select another theme.

  3. tranhien1945
    Member
    Posted 2 years ago #

    Maybe you installed some plugin the conflict other in your site.
    You can remove some plugin to from hosting and retry.
    If trouble, tell me plesase
    my site some troule like you before: [link moderated - please start your own topic]

  4. PepperedSugar
    Member
    Posted 2 years ago #

    I feel so dumb saying this, but, I don't know how to FTP and rename. I can't get into my dashboard. Literally as soon as I log in it goes to the error and will not do anything else. I can't get into anything and have no idea what to do.

    Is there some way to by-pass this and get into the code maybe? If so can you please explain how, because I have been researching and fighting with this baby for a month now, and so far all I have done is lost money, since I pay for the blog! I really don't want to delete my site, please help!

    And thank you to the guys that have already posted with help, trouble is I don't really know how to follow your guidance, and I apologize for that.

  5. Matthew Gedeon
    Member
    Posted 2 years ago #

    FTP stands for file transfer protocol. You can use a program like filezilla to access your files without loggin in. To figure out how to get your ftp information, you'll want to check your hosts forums. Once you log in, you'll be at the root of your site. You may need to go into your htmldocs folder before you find what you're looking for, but you are looking for "wp-content", then "themes", then you'll need to rename the folder that is for the theme you are using Then try loging in. If that doesn't work, try going into the folder for that theme, and finding "style.css" and renaming that.

  6. PepperedSugar
    Member
    Posted 2 years ago #

    alright folks, I have made it into my FTP, (I believe) and have found the "wp-content" and "themes" and even found the offensive theme, but when I mouseover it (it won't let me directly open it), it pops up at the bottom all that is in it; archives, languages, 404, comments, etc. I can't seem to find out how to change the actual name of the folder though. Am I in the wrong place?
    And seriously, thank all you guys for all the help so far, I really really appreciate it!

  7. PepperedSugar
    Member
    Posted 2 years ago #

    Oh, filezilla says the same thing, that it cannot connect to server, but I may be using it wrong too, it's my first time!

  8. PepperedSugar
    Member
    Posted 2 years ago #

    Okay, clearly I have no clue whatsoever about what I am doing! I tried changing the names like everyone said, and here are my new errors! I'm not sure if it's a good thing or not, but at least it's different!

    Warning: require_once(/home/mystuff/public_html/wp-content/themes/zombie-apocalypse/zombie-admin-functions.php) [function.require-once]: failed to open stream: No such file or directory in /home/mystuff/public_html/wp-content/themes/zombie-apocalypse/functions.php on line 4

    Fatal error: require_once() [function.require]: Failed opening required '/home/mystuff/public_html/wp-content/themes/zombie-apocalypse/zombie-admin-functions.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/mystuff/public_html/wp-content/themes/zombie-apocalypse/functions.php on line 4

    *sigh* Any ideas?

  9. PepperedSugar
    Member
    Posted 1 year ago #

    Changed everything back, so I'm back to the original errors. Does anyone know who I can contact perhaps to get this fixed? I am paying for this blog only to have it not work and WP tell me to talk to the forums. There has to be some way to get this fixed other than having to delete my blog...

  10. Matthew Gedeon
    Member
    Posted 1 year ago #

    You're on the right track. First of all, let me explain that somewhere in the theme there is bad code and it is doing what most code does when it isn't written right...it's freaking out.
    If you have made any changes to the theme, then first grab the zombie apocalypse folder and drag and drop it to your computer to make a backup copy.
    Next Delete the folder, then try logging in. DO NOT DELETE ANYTHING ELSE but the folder and the files in it. (filezilla will give you a list of everything it is deleting so don't freak out, that's just all the files that are in that folder.) Delete by right clicking (or command click for Mac users) and going down to "delete" in the menu. Remember, only the zombie apocalypse theme, not the whole themes folder.
    By the way, what service are you using to host your blog? Some come with support, however if you have godaddy, I can tell you they don't support anything that isn't directly their problem as a general rule.

Topic Closed

This topic has been closed to new replies.

About this Topic