WordPress.org

Ready to get started?Download WordPress

Forums

Ultimate Blogroll
[resolved] PLEASE HELP - Plugin not working properly (24 posts)

  1. Diekleinenic
    Member
    Posted 1 year ago #

    Just two days ago everything was working fine

    Now I checked the page I had set as the ONE page for the plugin and nothing is displaying, the page is simply empty :(

    Please help

    http://wordpress.org/extend/plugins/ultimate-blogroll/

  2. Schrank
    Member
    Posted 1 year ago #

    I have the same Problem since i use the jetpack

  3. ThorsDad
    Member
    Posted 1 year ago #

    I have the same problem. Ultimate Blogroll had been working on my sites now the pages are blank. Fix?

  4. jensg
    Member
    Plugin Author

    Posted 1 year ago #

    First of all I am sorry for my delayed reaction. New house, new job, I am now settled and have time to work on Ultimate Blogroll. I will continue to support Ultimate Blogroll I am currently making a list of all the bugs and possible improvements. Do you have anything that disturbs you?

  5. jensg
    Member
    Plugin Author

    Posted 1 year ago #

    Could you give me some more details so I can reproduce the problem? I am unable to recreate your problem.

  6. ThorsDad
    Member
    Posted 1 year ago #

    My Link Page

    Warning: Missing argument 2 for wpdb::prepare(), called in /usr/home/photoenv/public_html/wordpress/wp-content/plugins/ultimate-blogroll/persistence/LinkpartnerMapper.php on line 64 and defined in /usr/home/photoenv/public_html/wordpress/wp-includes/wp-db.php on line 990

    This shows on all my Ultimate Blogroll pages.

  7. jensg
    Member
    Plugin Author

    Posted 1 year ago #

    I have released version 2.4.1.1 today, that should solve your problem. In the new version I added a second argument (where needed) or removed the prepare function (which should solve all the problems). In this specific case (line 64) I removed the prepare function. Try the new version, it should show up in your plugin page, if it does not just wait a little while, WordPress only checks x times a day to see if there are new versions.

    Edit: Is this the same problem you described before? I don't know what you mean by blank pages, I can't seem to reproduce it. Do you have more details?

  8. ThorsDad
    Member
    Posted 1 year ago #

    The error is gone but I am back to a blank page.

    The page contains <!--ultimate-blogroll--> but nothing appears as the NSFW link in my previous post shows.

  9. jensg
    Member
    Plugin Author

    Posted 1 year ago #

    That's weird, what does your error_log says? Clearly something goes wrong, I guess it is surpressed but still logged. Do you have any more information? I can see that there is a blank page, but I can't reproduce it (which I need to be able to, to solve it).

  10. jensg
    Member
    Plugin Author

    Posted 1 year ago #

    Could you create me a wordpress admin account, with read and write access on the ultimate blogroll directory and access to the error_log? I will happily solve this issue, but I need more information.

  11. jensg
    Member
    Plugin Author

    Posted 1 year ago #

    Are you sure you have set an ultimate blogroll page? The <!--ultimate-blogroll--> tag is obsolote and is replaced with a new way. In the settings page you can select the page of your choice, or you can go directly to your page in edit mode. In the right column you will find an admin widget, toggle the page to true.

    If that fixes your issue, then somewhere in between a version the conversion went wrong and I will fix that.

  12. ThorsDad
    Member
    Posted 1 year ago #

    As Diekleinenic said Ultimate Blogroll used to work then stopped.

    I can set you up with admin access but need your email to send it to you.

  13. jensg
    Member
    Plugin Author

    Posted 1 year ago #

    I fixed the addlink problem, I thought I did before but there was still another issue. To prevent name collisions I have added namespaces. Could you check if this solves your issue. I would like to give you my email address but I also don't like spam. You could fill in this form: http://ultimateblogroll.gheerardyn.be/bug-report with your real email address and I will get back to you.

  14. ThorsDad
    Member
    Posted 1 year ago #

    I just installed the new version and received a "Plugin could not be activated because it triggered a fatal error."

    Parse error: syntax error, unexpected T_STRING, expecting ')' in /usr/home/dirtymind-games/public_html/sexgames/wp-content/plugins/ultimate-blogroll/ultimate-blogroll.php on line 44

  15. jensg
    Member
    Plugin Author

    Posted 1 year ago #

    I just installed the new version and received a "Plugin could not be activated because it triggered a fatal error."

    Parse error: syntax error, unexpected T_STRING, expecting ')' in /usr/home/dirtymind-games/public_html/sexgames/wp-content/plugins/ultimate-blogroll/ultimate-blogroll.php on line 44

    I introduced namespaces to solve name conflicts, this is a php 5 feature. You should try to update your php version.

  16. jensg
    Member
    Plugin Author

    Posted 1 year ago #

    The plugin requires at least php 5.3

  17. ThorsDad
    Member
    Posted 1 year ago #

    I'm at php 5.2. I guess I'll have to figure out how to update it.

  18. jensg
    Member
    Plugin Author

    Posted 1 year ago #

    Yesterday I released a new version 2.4.3 which solves this issue, although I recommend you update your php. There are apparantly a lot of people who are running an unsecured server, although I shouldn't encourage support for < php 5.3 I added support for it. My mind is blowen by the amount of people running unpatched software...

  19. jensg
    Member
    Plugin Author

    Posted 1 year ago #

    Could you check if it is working now? I refactored the plugin in a way that it should support your installation.

  20. ThorsDad
    Member
    Posted 1 year ago #

    I just updated the plugin on a couple of my sites. No more error messages but the Ultimate Blogroll page still comes up blank.

  21. jensg
    Member
    Plugin Author

    Posted 1 year ago #

    The plugin used the tag <!--ultimate-blogroll--> but now uses another way. There was a problem to import older settings see here
    Your issues should be resolved, unless you say otherwise.

  22. jensg
    Member
    Plugin Author

    Posted 1 year ago #

    Could you contact me throught this form? If you could give me an admin account (and maybe ftp access) I will take a look at it. I don't like spam so I won't post my email address here in the open.

  23. jensg
    Member
    Plugin Author

    Posted 1 year ago #

    Could you create a new topic since this one is closed and there is no option to reopen it?

  24. huggahoodie
    Member
    Posted 1 year ago #

    Hi Just installed this plug in version 2.5.1 and got error message on admin page: Fatal error: Cannot redeclare admin_menu() (previously declared in D:\xampp\htdocs\wordpress\wp-content\plugins\wp-e-commerce\wpsc-widgets\admin_menu_widget.php:99) in D:\xampp\htdocs\wordpress\wp-content\plugins\ultimate-blogroll\ultimate-blogroll.php on line 180, looked for you support and then gone back to version 2.3.1 as per latest on your support site and now getting this error: Fatal error: Call to undefined method Widget::GetLimit() in D:\xampp\htdocs\wordpress\wp-content\plugins\ultimate-blogroll\domain\Widget.php on line 27
    Any help would be appreciated,
    Regards

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.