WordPress.org

Ready to get started?Download WordPress

Forums

Please, help me with wp-config settings (19 posts)

  1. Swoopr
    Member
    Posted 9 years ago #

    I'm begginer and I have problem withwp-config.php settings.
    I write this:

    <?php
    /** WordPress's config file **/
    /** http://wordpress.org/ **/
    // ** MySQL settings ** //
    define('DB_NAME', 'blog_swoop_name'); // The name of the database
    define('DB_USER', 'blog.swoop.name'); // Your MySQL username
    define('DB_PASSWORD', '********'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value
    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = 'wp_'; // example: 'wp_' or 'b2' or 'mylogin_'
    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', 'cs_CZ');
    /* Stop editing */
    $server = DB_HOST;
    $loginsql = DB_USER;
    $passsql = DB_PASSWORD;
    $base = DB_NAME;
    define('ABSPATH', dirname(__FILE__).'/');
    // Get everything else
    require_once(ABSPATH.'wp-settings.php');
    ?>

    but browser wrote me:
    Error establishing a database connection! This probably means that the connection information in your wp-config.php file is incorrect. Double check it and try again.
    * Are you sure you have the correct user/password?
    * Are you sure that you have typed the correct hostname?
    * Are you sure that the database server is running?
    WHAT'S WRONG?
    My blog adress is: http://www.swoop.name/blog/
    Thank you for fast reply. I'm really hopeless.

  2. Swoopr
    Member
    Posted 9 years ago #

    BTW: My password, login and DB name are right. I'm surre.

  3. Mark (podz)
    Support Maven
    Posted 9 years ago #

  4. Swoopr
    Member
    Posted 9 years ago #

    Thank you, but i can't find solution of my problem... I try fast everything..

  5. Mark (podz)
    Support Maven
    Posted 9 years ago #

    If you email me with some login information for your cpanel, I'll find the settings for you.
    tamba2 at gmail dot com

  6. Swoopr
    Member
    Posted 9 years ago #

    BTW, what's cpanel?

  7. Swoopr
    Member
    Posted 9 years ago #

    If you mean access to my domain, ... thats only my. But anything else i send you. No problem

  8. Mark (podz)
    Support Maven
    Posted 9 years ago #

    How did you set up the database ?

  9. Swoopr
    Member
    Posted 9 years ago #

    I have hosting by PIPNI.cz. There are formular. Into this i have put my database name, and password. All else is generated by robot. Robot expand the DB name about my domain name.
    Example: i fill this DB name: blog
    Robot expand it on _swoop_name
    Result DB name: blog_swoop_name
    Login is the same, but instead of _ is . (dot)

  10. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Is 'localhost' definitely correct ?

  11. Swoopr
    Member
    Posted 9 years ago #

    That i don't know sure. I installed WP into folder "blog".
    adress these is: http://www.swoop.name/blog/
    The exact adress is: /DISC2/WWW2/SWOOP.NAME/BLOG/
    I's it possible that is wrong this parameter wp-config.php:
    define('ABSPATH', dirname(__FILE__).'/');

  12. Mark (podz)
    Support Maven
    Posted 9 years ago #

    No, there is nothing wrong with the file.
    The error is in one of the 4 pieces of information that you have given WP.
    On your host pages, it should mention the DB_Connection string ?
    Is localhost in that ?

  13. dissurion
    Member
    Posted 9 years ago #

    MySQL Server : mysql
    MySQL Database : yourdomain_com or name_yourdomain_com
    MySQL Login : yourdomain.com or name.yourdomain.com
    (http://new.pipni.cz/napoveda.phtml?akce=jazyk)
    These look different from the values you entered. Eg I would enter 'swoop.name' as user instead of 'blog.swoop.name'. But you say you are sure of them?

  14. dissurion
    Member
    Posted 9 years ago #

    If the connection can be made I believe it would give you an error on the password/user. So there is no connection to the mysql server in the first place (and so also no checking whether you user/pass is correct).
    First focus on the 'localhost'. One of the 20 possibilities will work.

  15. Swoopr
    Member
    Posted 9 years ago #

    What looks different? I mean thats everything inserted right.. My opinion is, thats problem with damn "localhost"..

  16. Mark (podz)
    Support Maven
    Posted 9 years ago #

    MySQL Server : mysql
    Try 'mysql' instead of 'localhost'

  17. Swoopr
    Member
    Posted 9 years ago #

    WoW!
    New Report!
    It doesn't look like you've installed WP yet. Try running install.php.

  18. Swoopr
    Member
    Posted 9 years ago #

    Thank you all very Much! You' re Great people.

  19. dissurion
    Member
    Posted 9 years ago #

    Cool. Looks like it's running at your site. Have fun. :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.