WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Please help me to set up a static page (3 posts)

  1. sleepymonk
    Member
    Posted 12 months ago #

    I am trying to set up a static page for the home page of my website. I had a home page set up, but when you click on the logo of my website, it hangs forever until you get a "this page has a redirect loop" error page.

    At this point I could care less whether or not it shows blog pages as I am running WooCommerce and that's all I really care about.

    I have followed the wp codex instructions but they don't work. I have set up a static page called 'test' and a blank page called 'blank' following these instructions.

    I have de-activated WP Supercache and deleted any code related to it in my htaccess file.

    As a result, I am getting a search box (from the theme) saying it can't find the static file. It can't even find the home page if I change it back to the default of blog posts.

    I have spent two days on this and have a web design person (not a tecchie) waiting to finish her job because she is going on vacation at the end of this week.

    I have tried to hire people in the past (for $$) to help with my website but nobody will help, they all say "you seem to know what you are doing, let me know when you're almost ready to go live". So diving into the unknown of hiring someone for this simple little thing is not palatable to me. I have researched as much as I can, but I am at a complete dead end.

    The theme I am using is Synapse child theme from Simple Themes.

    My site is not live because it is a replacement for my html website and the dev site is under maintenance mode.

    Can someone please help me? Please don't mark this post as resolved. It's not.

  2. WPyogi
    Volunteer Moderator
    Posted 12 months ago #

    Have you tried deactivating all plugins and switching to the default twentytwelve theme to start troubleshooting this problem?

    See if you can create a static home page there. If so, switch to the unmodified, parent theme and test it. If that's okay, switch to your child theme and test it.

    If that work, start reactivating your plugins one by one, to see where the problem pops up.

  3. sleepymonk
    Member
    Posted 12 months ago #

    Thanks, WPyogi. I did try all of those things.

    The theme developer just logged in to my site and fixed it for me. I had to give him admin access.

    It looks like there was a problem with the “Custom Permalinks” plugin. The “test” page which is set as the home page was also an entry in the plugin. The plugin was attempting to redirect to / to /test which was attempting to redirect back to /. This is called a redirect loop which WP forwards to a 404 to keep your server from crashing.

    I removed the “test” entry from the plugin’s settings page and that seems to have resolved the issue.

    Note to self: To be specific, don't put the page title in the custom permalinks field!

    I am posting this so that someone else may benefit from my mistake and solution. I spent about two days trying to figure this out. It was actually quite simple but I just couldn't see it.

    Thanks again.

Reply

You must log in to post.

About this Topic