WordPress.org

Ready to get started?Download WordPress

Forums

please help me figure out why IE is being an a hole to my site (centering issue) (5 posts)

  1. mixmastermichael
    Member
    Posted 4 years ago #

    hi,

    so, on my site, I would like to add a shadow background image, which I've done and works great in mozilla and chrome.

    http://www.betasab.host56.com

    IE however does not support this behavior where it aligns the site to the left for some reason and it's driving me crazy.

    I am not sure what the issue is, all I've done, is added a div and id, margins - auto for left and right.

  2. The first problem is that you've got a <div id="wrapper"> in your header.php (in your theme) above the <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">. Nothing should be above that DOCTYPE line. Fix that and then see if the IE problem goes away. It might not, as there are other errors in your site code and your theme. Did you edit Shades of Blue?

  3. mixmastermichael
    Member
    Posted 4 years ago #

    Yes, I used Shades of Blue theme.

    I can't seem to get that to work, when I inserted the <div id="wrapper"> I did it inside the index (main template.php above the head.er.php. When I try it below, it doesn't work...

    The wrapper div being above the doctype does seem to be the problem though, anyone have any ideas on how I might be able to just get the shadow to be placed as it should in IE?

    Thanks!

  4. Then take it out of where you put it the in index.php file. It's still the main problem you're having. Until you fix that, your site will not display right. If you edited shades of blue, then get a fresh, undedited copy and find the correct place in index.php that the div wrapper goes.

  5. mixmastermichael
    Member
    Posted 4 years ago #

    Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags