WordPress.org

Ready to get started?Download WordPress

Forums

I need to put one div on after first post (4 posts)

  1. gkkit
    Member
    Posted 7 months ago #

    please help

    <?php global $theme; ?>
    
        <div <?php post_class('post clearfix'); ?> id="post-<?php the_ID(); ?>">
    
            <h2 class="title"><a>" title="<?php printf( esc_attr__( 'Permalink to %s', 'themater' ), the_title_attribute( 'echo=0' ) ); ?>" rel="bookmark"><?php the_title(); ?></a></h2>
    
            <div class="postmeta-primary">
    
                <span class="meta_date"><?php echo get_the_date(); ?></span>
                  <span class="meta_categories"><?php the_category(', '); ?></span>
    
                    <?php if(comments_open( get_the_ID() ))  {
                        ?>   <span class="meta_comments"><?php comments_popup_link( __( 'No comments', 'themater' ), __( '1 Comment', 'themater' ), __( '% Comments', 'themater' ) ); ?></span><?php
                    } ?>
            </div>
    
            <div class="entry clearfix">
    
                <?php
                    if(has_post_thumbnail())  {
                        ?><a>"><?php the_post_thumbnail(
                            array($theme->get_option('featured_image_width'), $theme->get_option('featured_image_height')),
                            array("class" => $theme->get_option('featured_image_position') . " featured_image")
                        ); ?></a><?php
                    }
                ?>
    
                <?php
                    the_content('');
                ?>
    
            </div>
    
            <?php if($theme->display('read_more')) { ?>
            <div class="readmore">
                <a>#more-<?php the_ID(); ?>" title="<?php printf( esc_attr__( 'Permalink to %s', 'themater' ), the_title_attribute( 'echo=0' ) ); ?>" rel="bookmark"><?php $theme->option('read_more'); ?></a>
            </div>
            <?php } ?>
    
        </div><!-- Post ID <?php the_ID(); ?> -->
  2. WPyogi
    Volunteer Moderator
    Posted 7 months ago #

    What theme is this? It's really not clear what you are trying to do - please explain a bit more. Please also see:

    http://codex.wordpress.org/Forum_Welcome#Posting_Code

    I fixed your code above.

  3. gkkit
    Member
    Posted 7 months ago #

    @WpyogI

    please check theme

    [non-GPL vendor link removed]

    i need to put one ad place on only after first post?
    its possible one theme?

  4. WPyogi
    Volunteer Moderator
    Posted 7 months ago #

    Unfortunately, that theme is not released under the GPL licensing requirements of WP - and we cannot support non-GPL themes here at all. You really should find another decent quality theme ASAP - those themes are not good - this explains more:

    http://www.chipbennett.net/2010/12/10/only-download-wordpress-themes-from-trusted-sources/

Reply

You must log in to post.

About this Topic

Tags