WordPress.org

Ready to get started?Download WordPress

Forums

Please Help: I have an Error that I don't understand (6 posts)

  1. bbreaux
    Member
    Posted 2 years ago #

    Ok so my blog and site were working fine until I tried to go to login last night and I get this error. How do I fix this someone please help I did nothing this just happened. THis is the error I'm getting

    Fatal error: Call to undefined function is_blog_installed() in /home/highlyflvrd09/endswealthcorp.com/site/wp-includes/load.php on line 430

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'wp_ob_end_flush_all' was given in /home/highlyflvrd09/endswealthcorp.com/site/wp-includes/plugin.php on line 405

  2. eswrite-wp
    Member
    Posted 2 years ago #

    That is a valid function. See reference information here, where they suggest that "If you use the default WordPress cache, and the database goes away, then you might have problems."

    Download the latest 3.3.1 WP install and see if replacing your function.php file (wp-includes/functions.php) will do the trick.

  3. bbreaux
    Member
    Posted 2 years ago #

    I tried replacing that file and I get a new error that reads…

    Fatal error: Call to undefined function untrailingslashit() in /home/highlyflvrd09/endswealthcorp.com/site/wp-includes/functions.php on line 387

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    What version of WordPress are you running?

  5. Chip Bennett
    Theme Review Admin
    Posted 2 years ago #

    What @esmi said:

    - What version of WordPress are you using?
    - What Theme are you using?
    - What Plugins are active?

  6. eswrite-wp
    Member
    Posted 2 years ago #

    @bbreaux

    Here's the reference for untrailingslashit(). Says that it's located in wp-includes/formatting.php. Instead of replacing that file, I think you need to do what esmi and Chip Bennett suggest: make sure you have a fully installed, latest version of WP. It looks like you have a mish-mash of incompatible core files.

Topic Closed

This topic has been closed to new replies.

About this Topic