WordPress.org

Ready to get started?Download WordPress

Forums

Please help 404 nothing found error on one post (14 posts)

  1. atok2
    Member
    Posted 9 months ago #

    Hi
    this is my website http://anthony-fitness.com and everything works great, i noticed on google webmaster tools that a couple of days ago one of my most popular post is returning the 404 nothing found error. http://anthony-fitness.com/methode-lafay/

    went on the website and the post is there but when i clic on it i get the error!

    But when i change the link to for exemple .com/methode-lafayy/ and save it, the post works.

    any ideas on how to fix this or why is this happening?

  2. bottleneck
    Member
    Posted 9 months ago #

  3. Lorenzo Orlando Caum
    Member
    Posted 9 months ago #

    Try un-publishing the post and then re-publishing it.

  4. bottleneck
    Member
    Posted 9 months ago #

    Moderator, may I ask, why my previous post won't appear here?

  5. esmi
    Forum Moderator
    Posted 9 months ago #

    If your posts get caught in the forum's spam filter (as these posts did), they have to be cleared out manually.

  6. bottleneck
    Member
    Posted 9 months ago #

    Okay, makes sense.

    Thank you.

  7. atok2
    Member
    Posted 9 months ago #

    @bottleneck i added the "la" in the url and it works, but i want it to work with my original link which is /methode-lafay/

    I un published and republished and its the same thing.

    I created a new post and used the url /methode-lafay/ it seems link the words methode-lafay are getting the error. is this even possible?

  8. bottleneck
    Member
    Posted 9 months ago #

    I would say there is a conflict between two posts URL's.

    Google cache reads your missing post correctly dated on September 9.

    If I were you, I would delete (sure, make a copy) each post, one by one, reset WP Total Cache plugin each time, and look up your missing post.

    You need to remove the offending post from the database completely, just to release its number.

    Make sure, when you move a post in Trash, it won't be deleted from the database, you need to click 'Delete permanently' after placing it in Trash.

  9. bottleneck
    Member
    Posted 9 months ago #

    I meant you need to delete posts published after September 9. It seems there are only two of them.

  10. atok2
    Member
    Posted 9 months ago #

    thank you for your help, but this didnt solve the problem.

    I deleted the two articles that i had made one was the same date when the error showed up and one after. cleared cache and still the same thing.

    What i dont understand is why this is happening and why this post not another one!

  11. bottleneck
    Member
    Posted 9 months ago #

    Let's change your permalink setting from 'post name' to 'month and name'.

    Clear cache, see what happens.

  12. atok2
    Member
    Posted 9 months ago #

    I changed the permalink as you said, well the page obviously worked since the url was different, but when i changed it back to post name i got the same error :/

  13. bottleneck
    Member
    Posted 9 months ago #

    You should've clicked on your link on the top of this thread after changing permalink setting:

    http://anthony-fitness.com/methode-lafay/

    If you see no 404 error and the page opens as

    http://anthony-fitness.com/2012/09/methode-lafay/

    just leave that permalink setting for good.

    In other words, that post won't give 404 anymore and Google finds that post as before.

  14. bottleneck
    Member
    Posted 9 months ago #

    Hey,

    my posts are being deleted so I am almost unable to reach you.

    Listen up.

    You should've clicked on your post link as it was appearing all the time after switching the permalink setting.

    Use the link "your domain com/methode-lafay/" on the top of this thread.

    If you see it comes up as "your domain com/2012/09/methode-lafay/"

    without 404, it's okay.

    Just leave it this way.
    Google won't give you an error either after the new permalink will be indexed.

    Hopefully, you will get this post and you will be okay as well.

Reply

You must log in to post.

About this Topic

Tags