WordPress.org

Ready to get started?Download WordPress

Forums

BuddyPress Links
[resolved] "Please fill in all of the required fields" (7 posts)

  1. Martyn_
    Member
    Posted 1 year ago #

    Does anyone know what causes the error above? I think this started happening somewhere around a bp 1.6 upgrade, but not 100% sure.

    http://wordpress.org/extend/plugins/buddypress-links/

  2. Martyn_
    Member
    Posted 1 year ago #

    Error logged is:

    PHP Fatal error: Class 'DOMDocument' not found in /website/wp-content/plugins/buddypress-links/bp-links-embed-classes.php on line 1134, referer: https://<domain>/links/create

    Workaround: remove <?php if ( !bp_get_link_details_form_name_desc_fields_display() ): ?> style="display: none;"<?php endif; ?> from L43 of buddypress-links/themes/bp-links-default/single/forms/details.php

    allows the manual entering of the field data...

  3. MrMaz
    Member
    Plugin Author

    Posted 11 months ago #

    The DOMDocument class is a core PHP class, so that is a really odd error.

    Either way, I think this is fixed in the 0.8.2 release, and at the very least, you can disable page fetching via settings now.

  4. Martyn_
    Member
    Posted 11 months ago #

    Just upgraded and still see the problem... however...

    Under centos 6.4 dom.so is not in the core php blob, it's a bolt-on in the php-xml package, and adding that resolves the issue - Should the plugin not have a class_exists() check added?

  5. AnywhereButHollywood
    Member
    Posted 11 months ago #

    I'm having this issue as well - please fill in all required fields. Using 0.8.2.
    Anyone else having this problem?

  6. AnywhereButHollywood
    Member
    Posted 11 months ago #

    Actually, I'm trying on another server now with a fresh install and this isn't happening... so go figure...

  7. MrMaz
    Member
    Plugin Author

    Posted 11 months ago #

    @Martyn_ the page fetching requires XML in order to parse the fetched web pages. I'm not sure if its a good idea to silently disable the feature because of a missing library, but I think I might add something to the plugin page that shows a warning if XML/DOM is missing

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.