WordPress.org

Ready to get started?Download WordPress

Forums

WordPress MU Domain Mapping
Please Check Why My Domain Mapping Is Not Working As It Should (10 posts)

  1. Johanhorak
    Member
    Posted 11 months ago #

    Hi

    Thanks for this plugin.

    I have Version 0.5.4.3 installed.

    I checked this procedure http://ottopress.com/2010/wordpress-3-0-multisite-domain-mapping-tutorial/ and noticed that I have no domain_mapping file in my mu plugins. I tried to add it but got an error.

    I have a blog network with a site at http://capetownholidayaccommodation.ilocals.info
    My domain is http://capeholidays.info

    I Jeremy from Jetpack said :

    I'm afraid the problem still exists; your site's address is still set to http://capetownholidayaccommodation.ilocals.info

    Can you have a look for me please and suggest how I should go about fixing it?

    http://wordpress.org/plugins/wordpress-mu-domain-mapping/

  2. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 11 months ago #

    Did you install through the plugin installer? If so then the location of domain_mapping.php is plugins/wordpress-mu-domain-mapping/domain_mapping.php.

    Domain Mapping does not change the internal address of your site. It just changes the URL on the front end of the site.

  3. Johanhorak
    Member
    Posted 11 months ago #

    Hi Ron

    Thanks for the support.

    I used the plugin installer.

    I had a problem with my Jetpack stats. My historical data was lost and I contacted Jetpack. They send me the following email that confused me and I am not sure if they are correct. Please have a look:

    We've been looking over your site, and it appears that there are some issues with the domain mapping configuration. If you view the source on your homepage (http://capeholidays.info/) you will notice that the capetownholidayaccommodation.ilocals.info URL is being used. With proper configuration, we would be seeing capeholidays.info instead.

    We also noticed that both http://capeholidays.info/ and http://capetownholidayaccommodation.ilocals.info load the same page. With proper configuration, capetownholidayaccommodation.ilocals.info would redirect to capeholidays.info instead. This not only can cause problems with Jetpack, but it might also cause problems with duplicate content in Google.

    I would recommend that you first straighten out the domain mapping configuration. I bet the folks over at http://wordpress.org/support/forum/multisite will be able to help you out.

    After that issue is resolved, we can get everything straightened out with Jetpack.

    Regards and thanks again.

  4. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 11 months ago #

    Set the mapped domain as the primary domain for the site. Go to the Domainn Mapping settings and ensure that the Primary Domain check is enabled.

  5. Johanhorak
    Member
    Posted 11 months ago #

    That's how it is. See the screen capture http://screencast.com/t/LEUnp9gF9

  6. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 11 months ago #

    Go to the Domain Mapping settings and ensure that the Primary Domain check is enabled.

  7. Johanhorak
    Member
    Posted 11 months ago #

    I thank you for your support.

    It must be frustrating to answer dumb questions to dumb users like me. Please accept my apology.

    I am obviously not doing it correctly. I thought the screen crab showed http://screencast.com/t/LEUnp9gF9 that I did what you suggested:

    Go to the Domain Mapping settings and ensure that the Primary Domain check is enabled.

    I have no clue what else you want me to do other than what I showed you.

  8. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 11 months ago #

    The screen I am referring to is the Domain Mapping settings screen vs the Domains screen.

    Network Admin ->Settings -> Domain Mapping. There are 5 checkboxes. The one I am referring to is the last one. It should not be checked.

  9. Johanhorak
    Member
    Posted 11 months ago #

    Hi Ron thanks for explaining it to me ;-)

    That's the way I have had it

    http://screencast.com/t/NzpJQDMSsEEC

    I wonder why Jetpack stats stuffed up then?

    Looking at my Server IP Address I see it's an old address and hostgator changed their stuff. I believe I need to update this Server IP Address to the new one.

    Thanks.

  10. Johanhorak
    Member
    Posted 11 months ago #

    I changed the IP Address. I think that will fix the issue. I will ask Jetpack to have a look again. Regards

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.