WordPress.org

Ready to get started?Download WordPress

Forums

HTML5 jQuery Audio Player
[resolved] Player suddenly not showing up (12 posts)

  1. anewlanguage
    Member
    Posted 1 year ago #

    I noticed suddenly the other day that the player is not loading on my site. Instead, where it should be, it displays the text "[hmp player]".

    Can't find any reason for the error. Any ideas?

    http://wordpress.org/extend/plugins/html5-jquery-audio-player/

  2. Maeve Lander
    Member
    Plugin Author

    Posted 1 year ago #

    Yep... looks like the shortcode is wrong.

    It should be [hmp_player] (note the underscore)

  3. anewlanguage
    Member
    Posted 1 year ago #

    Actually I made a mistake (it was black text on dark background)... but it does actually say [hmp_player]. It's on this page towards the right side: http://www.nowdenial.net/

  4. Maeve Lander
    Member
    Plugin Author

    Posted 1 year ago #

    Is it in a sidebar as a widget? Because the player doesn't currently work particularly well as a widget.

    This is one of the features being included in next major release...

  5. anewlanguage
    Member
    Posted 1 year ago #

    Yes it is being used as a widget. It's worked perfectly fine up until very recently though. Maybe there was a WP update that made it not work anymore.

  6. Maeve Lander
    Member
    Plugin Author

    Posted 1 year ago #

    Ok yeah I think that's almost certainly the problem. Just to confirm that though, maybe try removing it from the widget and placing it in a normal page as a test. If it works, then yes it's definitely a widget issue.

    On the bright side, I have just launched version 2.0 and the Pro version has much better widget support in this, so if it is definitely a widget issue then please install latest version and hopefully that should correct the problem

  7. anewlanguage
    Member
    Posted 1 year ago #

    Just updated to the newest version. Looks like it does work when put on a page, but still nothing in the widget for some reason.

  8. Maeve Lander
    Member
    Plugin Author

    Posted 1 year ago #

    You can't put more than 1 player on the same page... so if it's in the page alone that will work, or if it's in the sidebar alone that will work.... but if it's in both the page and the sidebar on the SAME page then neither player will display properly.

    Re the new widget feature.... did you drag across the actual widget? Or did you try putting shortcode in a text widget? Because for new version 2.0 there is an actual dedicated widget for the player...

  9. anewlanguage
    Member
    Posted 1 year ago #

    I was using the player on the sidebar of the news page, and every other page uses full-width with no sidebar. So only once on the same page.

    I have the shortcode in a text widget... I don't have an option to put a dedicated widget on there... nothing new showed up in the widgets page after I updated the plugin.

  10. Maeve Lander
    Member
    Plugin Author

    Posted 1 year ago #

    In Pro Version 2.0 your Appearance > Widgets area should have a new widget like this screenshot.

    Does yours not look like that?

    You can't use the regular shortcode in a plain text widget - it just doesn't work that way - you have to use the dedicated widget.

  11. anewlanguage
    Member
    Posted 1 year ago #

    I don't see that anywhere. Is that not in the free version?

  12. Maeve Lander
    Member
    Plugin Author

    Posted 1 year ago #

    No sorry its Pro only for this feature

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.