WordPress.org

Ready to get started?Download WordPress

Forums

podPress
[resolved] Player not displayed as intended (6 posts)

  1. fert
    Member
    Posted 11 months ago #

    The PodPress player is not displayed in the posts the way it is intended and it is displayed in the settings.

    Visit this post for example:

    http://www.urgeschmack.de/sollten-wir-milch-trinken-urgeschmack-podcast-21/

    I have no idea why PodPress choses to display a round button (or a suqare player after clicking on it) instead of the 1PixelOut (or whatever it's called) player.

    Also: Is there a shortcode to display a posts podcast anywhere in the text instead of the default beginning or end positions?

    http://wordpress.org/extend/plugins/podpress/

  2. ntm
    Member
    Plugin Author

    Posted 11 months ago #

    I have no idea why PodPress choses to display a round button (or a suqare player after clicking on it) instead of the 1PixelOut (or whatever it's called) player.

    Chrome (, Safari and IE9+) does not need a browser plugin to play .mp3 files that is why podPress embeds the .mp3 files with a different technique then in the other browsers by default. The 1PixelOut player is only visible in browsers which can not play such files on their own. In these browser podPress adds this Flash-based player.
    My big plan for this year is to implement a solution which displays always an equal looking player in all browsers.
    But for now you could leave the settings as they are or you could deactivate the option "Use HTML5 tags:" which you can find on the player settings page.

    btw: You should update the cache memory of the cache plugin. Because at the moment, when you open this post e.g. with Firefox, you will only some javascript errors and no player.

    Is there a shortcode to display a posts podcast anywhere in the text instead of the default beginning or end positions?

    Yes. [display_podcast] is the placeholder you could use.

  3. fert
    Member
    Posted 11 months ago #

    Hi and thanks for the quick reply.

    I tried deactivating "Use HTML5 Tags" but then no player gets displayed at all (in Chrome).

    I think the solitary "Play" button does not look as inviting as the 1PixelOut player - it just feels too... small, too unimportant. So I am looking forward to your new solution.

    Thanks for the shortcode, I couldn't find it anywhere. Maybe you could add them to the FAQ?

  4. fert
    Member
    Posted 11 months ago #

    Oh - and I just realized that the player is not at all displayed in Firefox. Just an empty space instead. I emptied the cache several times. What's wrong there?

  5. ntm
    Member
    Plugin Author

    Posted 11 months ago #

    I'm not sure. But at first try to find out what happens when you deactivate the Cache plugin (temporarily). Does the player appear when you do that?
    If it does appear then cycle through the settings of the Cache plugin and find out whether there is an option in regard to caching of the Javascript files. Because there are some Javasript errors on the pages with the Flash-based which occur because some of the JS functions of podPress are not loaded correctly.
    It seems to me that the function which minifies the source code of your blog is the most problamtic one.

  6. fert
    Member
    Posted 11 months ago #

    Yes, it was the caching. I just did not realize it because it works in Chrome. I had added the /podpress/players/1pixelout/1pixelout_audio-player.js file to the minify section and that killed it for firefox.

    Thank you!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.