WordPress.org

Ready to get started?Download WordPress

Forums

Play Audion (8 posts)

  1. drwinn
    Member
    Posted 8 years ago #

    Is there a way to play an audio within a post that does not include opening a seperate window for the player to work.

  2. McShelby
    Member
    Posted 8 years ago #

    I can recommend the EMFF. This can be downloaded from http://www.marcreichelt.de/spezial/musicplayer/ I am using this on my pages without any problems. It works as expected with at least Firefox, IE and Opera (that were the browsers I've used for tests).

    The EMFF can play automatically, in loops, with or without grafical interface but only mp3 format. If you want to play .wav, you first have to convert the .wav files to .mp3 by yourself.

  3. drwinn
    Member
    Posted 8 years ago #

    Thanks, I used the code generator and placed it in a WordPress post and it doesn't show up in the post.

    What might I be doing wrong?

  4. winterwish
    Member
    Posted 8 years ago #

    Maybe you might wanna try Flash Filter Plus
    http://redalt.com/downloads/

    From the site

    This plugin makes it easy to insert single MP3 files directly into your posts via a little Flash player.

  5. McShelby
    Member
    Posted 8 years ago #

    Thats the same technique the EMFF is using.

    I had some problems, integrating the OBJECT HTML tag inside of my post, because some of WPs plugins (I guess namely texturize) scrambled my XHTML and made it invalid (nesting of tags was somehow broken).

    For an example, you may take a look to one of my post at http://soeren-weber.net/post/2001/07/17/77/ Look for the OBJECT tag.

    Anyway, were can I see one of your attempts?

  6. drwinn
    Member
    Posted 8 years ago #

    Here is the address on by blog:

    http://drwinn.com/2005/09/16/watch-what-you-say/

    The two rather large white spaces have objects listed. The first one worked well on the original page when I posted it but when going to link page it simply does not appear.

  7. McShelby
    Member
    Posted 8 years ago #

    There are a few problems with your page. It's not validating as XHTML 1.0 Strict! So first fix this, and then your MP3 problem.

    I guess the reason why EMFF is not playing your sound after loading the page, is because you haven't autostarted it. Add the following string to both the "data" attribute of the "object" tag and the "value" attribute of the "param name="movie"" tag:

    &autostart=yes;

    You may quicken load time when adding the optional streaming parameter aswell:

    &streaming=yes

    Of the other Flash Players I am not sure why they aren't playing.

  8. outofsync
    Member
    Posted 8 years ago #

    hi, just joined this. i think i want to do the same thing as darwin. i want the sound (an mp3, small) to play as a rollover, but without opening a big page with the player on it.
    any advice?
    norie

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.