WordPress.org

Ready to get started?Download WordPress

Forums

Plaintxblog issue in IE (5 posts)

  1. Moominmama
    Member
    Posted 8 years ago #

    I'm using plaintxtblog as my theme and it's screwed in most but apparently not all (say my readers) versions of IE. I've read through all of the IE/theme posts (honest) and am still clueless about what to do. I've been futzing with the stylesheet and the templates but nothing so far has worked. I thought maybe it was a blogads issue but removing them didn't help. Then I messed with the width tags. I also removed bits and pieces from the sidebar to try to nail down what exactly was messing with it but no luck. I was looking at doing the IE CSS hacks but I don't know what attributes to change to make that work so no go just yet.

    I'm really thinking it's a CSS problem but don't know where to go to fix it.

    It looks like other people w/this theme are having the same problem so I did send an email to the very nice, very responsive but surely very busy designer and haven't heard yet.

    Here's my site: http://www.thiswomanswork.com
    and here's my stylesheet: http://www.thiswomanswork.com/wp-content/themes/plaintxtblog-20/style.css

    TIA!

  2. ktinkel
    Member
    Posted 8 years ago #

    Did you notice the warning that appears on the very bottom of your page:

    -----------------------------------------------------------
    Warning: Unknown: Your script possibly relies on a session side-effect which existed until PHP 4.2.3. Please be advised that the session extension does not consider global variables as a source of data, unless register_globals is enabled. You can disable this functionality and this warning by setting session.bug_compat_42 or session.bug_compat_warn to off, respectively. in Unknown on line 0
    -----------------------------------------------------------

    I wonder if that has something to do with your problems.

    I checked your site in these browsers: Firefox, Safari, Camino, Opera, and MSIE 5.2.3, all on a Mac.

    The only one that shows the two side columns correctly (I assume — as two distinct columns) is MSIE 5. But the main text area is placed below the side columns (common problem with MSIE).

    In all the others, the two narrow columns sort of overlap and commingle. (Usually, Mac and Win Firefox have identical results; and Firefox and Mozilla also usually have similar results.)

    Aside from the PHP issue, I agree with you: it is the CSS, probably in your width (etc.) properties. I am especially suspicious about the total widths of all the columns, including margins, borders, and padding.

    You could try changing narrowcolumn from 59% to, say, 57%. That might help. (For MSIE 6, I usually allow 2% slop — in a column gutter — to compensate for its inability to measure correctly! So make sure the total of all widths is 98% or less.)

    Have you validated your HTML and CSS at W3C.org? If you fail, they provide a list that shows where the problems are, with line numbers.

    That is all I can think of. Best of luck with it.

    (BTW: I am also a writer using one of Scott’s themes, Minimalist Sandbox. His work must appeal to writers!)

  3. Moominmama
    Member
    Posted 8 years ago #

    I've validated! Three entries are coming up wonky but the template is clean and I'll be fixing the entries as I go.

    Things are still wacky (and somehow validating created yet more wackiness) so I'm digging around. It's always a work in progress, eh?

    Thank you for your help!!

    And if I solve my issues I'll be sure to come back here and close this out.

  4. Moominmama
    Member
    Posted 8 years ago #

    I'm not sure how to edit this to make it closed so I'll say what I did. I validated the stylesheets and the mark-up and eliminated all of the errors but the columns still wouldn't work. I messed with the width tags and got things close but the blogads were just hugely problematic so I finally eliminated one of the columns completely in the index.php file.

  5. yosemite
    Member
    Posted 8 years ago #

    To mark resolved, scroll to top and use the pull-down menu.

Topic Closed

This topic has been closed to new replies.

About this Topic