WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
place order error page using cardsave gateway (3 posts)

  1. rikardo85
    Member
    Posted 1 year ago #

    Hello,

    I am having a problem when I am integrating the cardsave payment gateway to the woocommerce plugin.

    On the checkout page, I review my cart and select place order and the following error appears:

    {"result":"failure","messages":"
    
        \n\t\t\t
        Action failed. Please refresh the page and retry.<\/li>\n\t\t\t
        First Name<\/strong> is a required field.<\/li>\n\t\t\t
        Last Name<\/strong> is a required field.<\/li>\n\t\t\t
        Address<\/strong> is a required field.<\/li>\n\t\t\t
        Town\/City<\/strong> is a required field.<\/li>\n\t\t\t
        Postcode<\/strong> is a required field.<\/li>\n\t\t\t
        Country<\/strong> is a required field.<\/li>\n\t\t\t
        Email Address<\/strong> is a required field.<\/li>\n\t\t\t
        Phone<\/strong> is a required field.<\/li>\n\t\t\t
        First Name<\/strong> is a required field.<\/li>\n\t\t\t
        Last Name<\/strong> is a required field.<\/li>\n\t\t\t
        Address<\/strong> is a required field.<\/li>\n\t\t\t
        Town\/City<\/strong> is a required field.<\/li>\n\t\t\t
        Postcode<\/strong> is a required field.<\/li>\n\t\t\t
        Country<\/strong> is a required field.<\/li>\n\t\t\t
        Invalid shipping method.<\/li>\n\t\t\t
        Invalid payment method.<\/li>\n\t<\/ul>","refresh":"false"}

    I tried adding a paypal account which all works fine. The issue only occurs when I select the cardsave payment type.

    Any help much appreciated

    http://wordpress.org/extend/plugins/woocommerce/

  2. julepb
    Member
    Posted 1 year ago #

    Hi,

    I get the exact same error when using the PayPal Payments Advanced payment gateway and also the default PayPal gateway. At this time, PayPal is the only gateway I am interested in using and I haven't investigated other options.

    I'm very interested in any solution someone may have.

    Thanks.

  3. rikardo85
    Member
    Posted 1 year ago #

    I have fixed the problem.

    Something so simple! I didn't add a payment page!

    Hope this works for you.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic