WordPress.org

Ready to get started?Download WordPress

Forums

WP-Piwik
[resolved] Piwik says: Please check URL and auth token. (7 posts)

  1. AmandaT
    Member
    Posted 1 year ago #

    I know the URL is correct and I've copy/pasted the code a dozen times. I also tried setting up another user to use that code.

    Here is my test script:

    [ Moderator note: please wrap code in backticks or use the code button. ]

    *** Test 1/2: SitesManager.getSitesWithAtLeastViewAccess ***
    Using: cURL
    SSL peer verification: enabled
    User Agent:
    Call: http://mygeekychristmas.com/piwik/?module=API&method=SitesManager.getSitesWithAtLeastViewAccess&format=XML&token_auth= + TOKEN
    Result:
    HTTP/1.1 200 OK
    Date: Wed, 07 Aug 2013 07:12:58 GMT
    Server: Apache
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma: no-cache
    Set-Cookie: PIWIK_SESSID=4b7a1bebd1ec6c80bb58177b77af07ab; path=/; HttpOnly
    Transfer-Encoding: chunked
    Content-Type: text/xml; charset=utf-8
    
    <?xml version="1.0" encoding="utf-8" ?>
    <result>
    	<row>
    		<idsite>1</idsite>
    		<name>My+Geeky+Christmas</name>
    		<main_url>http://mygeekychristmas.com</main_url>
    		<ts_created>2013-08-07 03:53:44</ts_created>
    		<ecommerce>0</ecommerce>
    		<sitesearch>1</sitesearch>
    		<sitesearch_keyword_parameters />
    		<sitesearch_category_parameters />
    		<timezone>America/Boise</timezone>
    		<currency>USD</currency>
    		<excluded_ips />
    		<excluded_parameters />
    		<excluded_user_agents />
    		<group />
    		<keep_url_fragment>0</keep_url_fragment>
    	</row>
    </result>
    Time: 0.73s
    
    *** Test 2/2: SitesManager.getSitesIdFromSiteUrl ***
    Using: cURL
    SSL peer verification: enabled
    User Agent:
    Call: http://mygeekychristmas.com/piwik/?module=API&method=SitesManager.getSitesIdFromSiteUrl&url=http%3A%2F%2Fmygeekychristmas.com&format=XML&token_auth= + TOKEN
    Result:
    HTTP/1.1 200 OK
    Date: Wed, 07 Aug 2013 07:12:58 GMT
    Server: Apache
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma: no-cache
    Set-Cookie: PIWIK_SESSID=9cb585ab29c738395a0d6ccc92d592bf; path=/; HttpOnly
    Transfer-Encoding: chunked
    Content-Type: text/xml; charset=utf-8
    
    <?xml version="1.0" encoding="utf-8" ?>
    <result>
    	<row>
    		<idsite>1</idsite>
    	</row>
    </result>
    Time: 0.73s

    http://wordpress.org/plugins/wp-piwik/

  2. Bash76
    Member
    Posted 1 year ago #

    I have the same issue with the URL. Everthing else works, the testscript also works, but the site is not tracked.

    I posted a thread in the WP-piwik forums 2 days ago. The thread was not authenticated until now ...

  3. revtog
    Member
    Posted 1 year ago #

    Same problem here. The issue occured on my site after updating wordpress to version 3.6. Is there a known compatibility problem?

    I have another site running on the same server but wordpress 3.5 and there the wp-piwik plugin works fine.

    Hope to get a solution or update soon.

    cheers

  4. skarck
    Member
    Posted 1 year ago #

    same here, occured after 3.6 update.

  5. braekling
    Member
    Plugin Author

    Posted 1 year ago #

    The latest release was tested with 3.6 and is working here. At the moment there are no known issues.

    Did you try to disable the caching functionality (tracking settings)? Recheck all your settings after disabling and be sure it works again before you re-enable caching.

  6. revtog
    Member
    Posted 1 year ago #

    Hmm crazy. Now it really works!

    For the others, here's what I did:

    - Disabled the Plugin
    - Deleted the Plugin (with all files!)
    - Verified that Piwik is running and reachable on my stats server
    - Re-Installed Plugin "WP-Piwik" through plugin search
    - Copied the auth_token from piwik API site
    - Activated Plugin
    - Typed the Piwik URL in the corresponding field and pasted the copied Auth Token and checked the option for auto configuration
    - Applied the new settings

    After this, the Site told me, that Piwik is running successfully. And indeed Piwik is tracking again :-).
    It seems, that this Problem occured after updating WP from 3.5 to 3.6 - or maybe a bad constellation within the universe :-)?

    Hope this "guide" helps.

    Cheers

  7. square_eyes
    Member
    Posted 9 months ago #

    Disabling cache worked for me.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags