WordPress.org

Ready to get started?Download WordPress

Forums

WP-Piwik
[resolved] Piwik did not answer. Please check your entered Piwik URL. (15 posts)

  1. StefanRisticDev
    Member
    Posted 5 months ago #

    Hello and thank you for taking a look at my problem. I've installed WP-Piwik on four new websites today, and I'm getting the same error on each.

    "Ein Fehler ist aufgetreten: Piwik did not answer. Please check your entered Piwik URL."

    Here are the results from the test script:

    *** Test 1/2: SitesManager.getSitesWithAtLeastViewAccess ***
    Using: cURL
    SSL peer verification: enabled
    User Agent:
    Call: http://www.stv-bs.ch/piwik/?module=API&method=SitesManager.getSitesWithAtLeastViewAccess&format=XML&token_auth= + TOKEN
    Result:
    
    Time: 0s
    
    *** Test 2/2: SitesManager.getSitesIdFromSiteUrl ***
    Using: cURL
    SSL peer verification: enabled
    User Agent:
    Call: http://www.stv-bs.ch/piwik/?module=API&method=SitesManager.getSitesIdFromSiteUrl&url=http%3A%2F%2Fwww.stv-bs.ch&format=XML&token_auth= + TOKEN
    Result:
    
    Time: 0s

    When I add the tracking code manually, Piwik works properly, but then we can't use the WP-Piwik stats from the dashboard for example(stats are empty).

    Any thoughts?

    Thanks.

    https://wordpress.org/plugins/wp-piwik/

  2. eXorus
    Member
    Posted 5 months ago #

    I have the same issue and I don't understand why.

    This plugin doesn't work ?

    Fresh install of wordpress 3.8.1
    Fresh install of piwik 2.0.3
    Fresh install of wp-piwik 0.9.9.8

    When I try to go to Support

    cURL is available.
    allow_url_fopen is enabled.

    When I try to run test script I need to wait a long time before to have

    *** Test 1/2: SitesManager.getSitesWithAtLeastViewAccess ***
    Using: cURL
    SSL peer verification: enabled
    User Agent:
    Call: http://blog.mydomain.com/analytics/?module=API&method=SitesManager.getSitesWithAtLeastViewAccess&format=XML&token_auth= + TOKEN
    Result:
    
    Time: 63.14s
    
    *** Test 2/2: SitesManager.getSitesIdFromSiteUrl ***
    Using: cURL
    SSL peer verification: enabled
    User Agent:
    Call: http://blog.mydomain.com/analytics/?module=API&method=SitesManager.getSitesIdFromSiteUrl&url=http%3A%2F%2Fvincent.dauce.fr&format=XML&token_auth= + TOKEN
    Result:
    
    Time: 63.1s

    Why it doesn't replace the token I gave ? because if I copy the Call it's work for me with my token

  3. Trafalgar Law
    Member
    Posted 5 months ago #

    Same here.

    On 2 websites all is fine, on the third i become this error.
    But url and token 100% correct!

    WP: 3.8.1
    WP-PIWIK: 0.9.9.8
    PIWIK: 2.0.3

  4. gingerling
    Member
    Posted 5 months ago #

    Same here. I have

    An error occured: Piwik did not answer. Please check your entered Piwik URL

    in the plugin home and

    An error occured: Please check URL and auth token. You need at least view access to one site.

    within the settings tab.

    I have tried several things - turning off casheing, made a user and gave them view acccess and used their individual auth code, several variations of the URL just in case. No luck.

  5. braekling
    Member
    Plugin Author

    Posted 5 months ago #

    Looks like the HTTP requests aren't send. There is no return code (e.g., 200 OK) shown.

    Maybe you are running a firewall or something similar which blocks outgoing HTTP requests? (Maybe you should ask your web host or have a look at your log files.)

  6. braekling
    Member
    Plugin Author

    Posted 5 months ago #

    You are running REST API? PHP API is not working at the moment with the latest version of Piwik.

  7. eXorus
    Member
    Posted 5 months ago #

    I used REST API and it doesn't work.

    The URL is working when I call from my computer.

    I have a firewall but what is the flow I need to open ? because WordPress and Piwik are on the same server. ?

  8. StefanRisticDev
    Member
    Posted 5 months ago #

    I'm running Rest API and Auth token...

  9. eXorus
    Member
    Posted 5 months ago #

    Ok it was an issue with my firewall.

    I didn't change my firewall but I change de URL to switch to localhost (http://localhost/).

    And added the virtual host

    <VirtualHost *:80>
            ServerName localhost
    
            DocumentRoot /home/myblog/www/analytics/
            <Directory /home/myblog/www/analytics/>
                    Options -Indexes FollowSymLinks MultiViews -ExecCGI
                    AllowOverride None
                    Order allow,deny
                    allow from all
            </Directory>
    </VirtualHost>
  10. gingerling
    Member
    Posted 5 months ago #

    I don't have a firewall. I reeeally need to fix this. Can we properly establish the cause?

    Thanks

    Anna

  11. andrew55
    Member
    Posted 4 months ago #

    I am using: Piwik URL (REST API):

    Getting same error: An error occured: Piwik did not answer. Please check your entered Piwik URL

    I tried different variations of url and no luck.

    Any idea on what can be done to resolve this? Thank you.

  12. andrew55
    Member
    Posted 4 months ago #

    Note: I had to use www in url to get it to work (nothing else worked) - hopefully this will help others having same issue.

  13. skycult
    Member
    Posted 4 months ago #

    Hi,
    I've exactly the same problem. Summary:

    • into one (public) server I've both wordpress and piwik in two different virtual servers:
      <VirtualHost *:443>
      ServerName piwik.mydomain.com
      DocumentRoot /var/www/piwik
      ....
      <VirtualHost *:80>
      ServerName http://www.mydomain.com
      DocumentRoot /var/www/wordpress
      ....
    • when I try to set Piwik URL (REST API) = https://piwik.mydomain.com I see:
      An error occured: Please check URL and auth token
    • when I try to use from the server console the same command that I see in test script, it works
    • when I try to use from my linux (outside the server farm) console the same command that I see in test script, it works
    • into another (public) server I've a website with a page with the piwik script and it works

    Update:
    if I set WP-Piwik to use http connection instead the https, it works.

    How I can solve this problem?
    Thanks!

  14. eXorus
    Member
    Posted 2 months ago #

    This topic is resolved with the new version
    Piwik 2.2.0 and WP-Piwik 0.9.9.10

    Thanks, now I'm using PHP API.

  15. gingerling
    Member
    Posted 2 months ago #

    I also got this working. I think the problem may have partially been caused by my site being in a cluster on a shared server.

    This is what my setup was like

    Piwik path (PHP API, beta): /home/cluster-sites/number/domain.co.uk/public_html/piwik

    Auth token: 3numbersandletters0 (note, only the numbers and letters not the text at the start)

    Also, I had to update to the latest plugin version too, Piwik 2.2.0 and WP-Piwik 0.9.9.10. For some reason I had to disable WP-Piwik before it would show me the update. The update for piwik itself came up in a bubble and I simply clicked though. :)

Reply

You must log in to post.

About this Plugin

About this Topic

Tags