WordPress.org

Ready to get started?Download WordPress

Forums

WP-Piwik
[resolved] "Piwik did not answer. Please check your entered Piwik URL" but wp-piwik works? (3 posts)

  1. Rodorm
    Member
    Posted 10 months ago #

    Hi,

    I have a strange problem with wp-piwik. I suddenly get the error "Piwik did not answer. Please check your entered Piwik URL" on all of my blogs, but wp-piwik still seems to work. I get statistics data. How can I debug this? The only thing I changed a few days ago was force_ssl_login = 1
    and force_ssl = 1. Changing that back to 0 doesn't solve the problem. The Apache log doesn't show anything unsual.
    The test script output looks normal:

    *** Test 1/2: SitesManager.getSitesWithAtLeastViewAccess ***
    Using: cURL
    SSL peer verification: enabled
    User Agent:
    Call: https://mypiwikpath?module=API&method=SitesManager.getSitesWithAtLeastViewAccess&format=XML&token_auth= + TOKEN
    Result:
    HTTP/1.1 200 OK
    Date: Wed, 11 Sep 2013 20:35:00 GMT
    Server: Apache
    Set-Cookie: PIWIK_SESSID=kpbcbqegiba72g6bel0qf1rrf5; path=/; secure; HttpOnly
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma: no-cache
    Vary: Accept-Encoding
    Content-Length: 6063
    Content-Type: text/xml; charset=utf-8
    
    <?xml version="1.0" encoding="utf-8" ?>
    <result>
    [Lots of correct XML data about my sites9
    </result>
    Time: 0.13s
    
    *** Test 2/2: SitesManager.getSitesIdFromSiteUrl ***
    Using: cURL
    SSL peer verification: enabled
    User Agent:
    Call: https://mypiwiksite/?module=API&method=SitesManager.getSitesIdFromSiteUrl&url=http%3A%2F%2Fwww.socialmedia-fuer-psychologen.de&format=XML&token_auth= + TOKEN
    Result:
    HTTP/1.1 200 OK
    Date: Wed, 11 Sep 2013 20:35:00 GMT
    Server: Apache
    Set-Cookie: PIWIK_SESSID=0dqs99hm1373oh45n63klpuer5; path=/; secure; HttpOnly
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma: no-cache
    Vary: Accept-Encoding
    Content-Length: 94
    Content-Type: text/xml; charset=utf-8
    
    <?xml version="1.0" encoding="utf-8" ?>
    <result>
    	<row>
    		<idsite>8</idsite>
    	</row>
    </result>
    Time: 0.1s

    [Moderator Note: Please post log files between backticks or use the code button.]

    http://wordpress.org/plugins/wp-piwik/

    TIA,

    Alex

  2. braekling
    Member
    Plugin Author

    Posted 9 months ago #

    Did you try to disable caching? (Settings -> tracking)

  3. Rodorm
    Member
    Posted 9 months ago #

    No, caching was enabled. Thanks for the hint. :-)

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.