WordPress.org

Ready to get started?Download WordPress

Forums

Really simple Facebook Twitter share buttons
[resolved] Pinterest button not showing (10 posts)

  1. kjfrank
    Member
    Posted 1 year ago #

    I have selected the pinterest button, set the width to 100 with show counter checked. The button does not show and the sousrce code shows an empty div where the button ought to be.

    <div class="really_simple_share_pinterest" style="width:100px;"></div>

    I am usinfg version 2.6.2 and am running wordpress 3.5

    Any help would be appreciated

    http://wordpress.org/extend/plugins/really-simple-facebook-twitter-share-buttons/

  2. whiletrue
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, please note that the PinIt button requires some media to share, so it only shows up when the post contains at least one image. Are you using images in your posts? If so, can you tell me the website url to perform some checks?

  3. kjfrank
    Member
    Posted 1 year ago #

    Thank you for the clarification... it does show up if I have a featured image assigned to the post., but not when I code an image "into" the post.
    Is that the correct behavior?

    Also I might suggest that in your "really-simple-facebook-twitter-share-buttons.php" you change the following line(line 244 I think) of code from:

    $out .= '<div style="height:'.$height.'px;" class="really_simple_share robots-nocontent snap_nopreview">';

    to

    $out .= '<div style="min-height:'.$height.'px;" class="really_simple_share robots-nocontent snap_nopreview">';

    Changing the "height" to "min-height" works much better in responsive designs and It doesn't appear to break anything. Let me know if you know of any issues with doing this. If not perhaps you could include it in your next update. then I can stop making the change manually each time I install updates to your plugin. Thank you again.

  4. whiletrue
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, the plugin tries to detect a picture, looking for the featured image, then an attachment, then looks into the post html; the latter code could probably be improved. Can you paste some samples of post html where an image wasn't recognized?

    As for the "min-height", thanks for your suggest. We just uploaded the new plugin version fixing that attribute.

  5. kjfrank
    Member
    Posted 1 year ago #

    Here is a simple post with one image that is not recognized.

    <div class="vp-post">
    <img class="alignleft size-full wp-image-395" alt="Bridgit Frank" src="http://my.domain.net/wp-content/uploads/2013/01/image.jpg" width="135" height="200">
    <p>Iaceo, nisl brevitas, ex modo, exputo ille gilvus, verto. Vereor iustum, exerci, vel abbas esca consequat lobortis. Letalis tristique velit commoveo praemitto fatua fatua elit dolore singularis enim ut ne persto.</p>
    <p>Aptent gemino enim capto uxor pecus neque. Singularis at vel, nimis proprius abbas mos. Vel hendrerit voco dignissim, nimis utrum volutpat. Os exerci exerci abluo vindico nostrud abigo odio tum, laoreet. Esse esse commoveo et vulputate, regula, verto regula, typicus typicus, wisi eros nostrud.Eros oppeto eros, multo feugait ideo. Minim minim, exerci vel quia antehabeo paulatim. Ventosus abluo exerci minim dolore genitus paratus, tation, similis sudo tego. Gravis quis diam consequat ymo, ille meus, mos sudo metuo iustum, suscipit macto. Scisco qui humo nulla diam ratis si nulla pertineo luptatum abluo ut premo zelus esse.</p>
    <p>Duis nibh consectetuer appellatio neque exerci tum luptatum nisl tincidunt tamen nulla velit. Iriure vel velit ingenium singularis venio veniam vereor. Vereor esca, jugis accumsan adsum ludus augue natu amet nulla facilisis.Vindico, delenit eligo, eros dolus nulla blandit brevitas acsi loquor bene. Vulpes illum quia eros luctus eu nostrud esse at. Oppeto os diam eu, duis, opes iusto, dignissim inhibeo ne opes, importunus plaga.</p>
    </div>

    As far as the min-height attribute change, how long until wordpress recognizes the new version and lets me know there is a new version so I can update it?

  6. kjfrank
    Member
    Posted 1 year ago #

    I see this ticket is marked as resolved but in my previous post, I sent you code in which the buttons are not showing for a post that contains an image(as you requested). I would still like to know if this issue is being worked on. Thank you.

  7. whiletrue
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, I tested your code on our site, the image gets recognized and the button is correctly shown.

    I tested using latest update of WP (3.5.1) and the plugin (2.6.3), with different configurations of Pinterest Button advanced settings (Use multiple image selector, Use old button code), always working.

    Can you tell me your website url to check something in your theme/code?

  8. kjfrank
    Member
    Posted 1 year ago #

    Whiletrue, thank you for your response. Here is a test post http://dev.villagepilates.net/test-3/

  9. panmac
    Member
    Posted 1 year ago #

    Hi - I know this is marked as resolved but I can't see how it was resolved, and I'm having the same problem -

    Running WP 3.5.1 and plugin 2.7

    I've got a site where there is a custom post type where images are inserted via custom fields, and sometimes the Pin It button recognizes the image and sometimes it doesn't and therefore doesn't show up.

    These are two nearly identical posts:

    http://billingsbridge.com/store-directory/booster-juice/

    http://billingsbridge.com/store-directory/coles-the-book-people/

    and yet the second one doesn't show the Pin It button, but in the source I can see the space where it should be.

    I've tested with the "use multiple image" option and all that does is remove the Pin It button and replace it with alt text. Switching to the "use old code" option changes nothing, the Pin It button still only shows on some pages and not others. I've also tried rearranging the order of the buttons, but that also changes nothing.

    If I add a featured image, of course the button shows up, but these posts only have the single image set and I would certainly prefer not to have to go in and set a featured image on each one just to use the button.

    Please advise, and thank you!

  10. whiletrue
    Member
    Plugin Author

    Posted 1 year ago #

    Hi bkglass,
    the new 2.9 plugin release, out today, should solve your Pinterest issue; if not, try to activate the "Always use multiple image selector" option.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic