WordPress.org

Ready to get started?Download WordPress

Forums

Pinboard
[resolved] Pinboard how to remove sticky post from blog page? (9 posts)

  1. buggsahoo
    Member
    Posted 1 year ago #

    The images that are in the slider are appearing on my blog page. I don't want that. How do I stop the slider images that are sticky from appearing on the blog page.

    I saw something about adding some php code to the functions.php file, but it was not specific for the Pinboard theme & it didn't say where to put it and I don't know PHP. Plus, it wanted me to add a child theme of Pinboard to do this.

    The domain is pointing to a holder page & I don't know how to subvert that so you can see the page to understand what I am asking.

    All help is appreciated and needed.

  2. redwren
    Member
    Posted 1 year ago #

    Hello,

    In your dashboard go to Appearance> Theme options> General :

    Scroll down to where it says "Home Page", find and UN-check the following:

    Sticky Posts Slider Display a slider of sticky posts on the front page.

    Your sticky posts will now appear without the slider!

  3. buggsahoo
    Member
    Posted 1 year ago #

    Sorry if my question was unclear.
    I want the slider to appear only on the home page (which it is), BUT the sticky posts (which are the featured slider images) are also appearing as POSTS on my BLOG page in the Pinboard theme. I do not want them to show there.
    Because the slider was set to function with sticky posts, there is not an option to set those "sticky post" to only appear in the slider and not the regular posts.

    I will try what you suggest, but I believe that will just disable the slider on the home page.

    Thanks for responding.

  4. redwren
    Member
    Posted 1 year ago #

    Hello,

    Yes, I think it will just disable the slider on your home page.

    Maybe try copying the browser address for the page?

    You may have to explore a work around such as changing the category of those sticky posts to "portfolio" to remove them from your regular blog post flow. I've heard this mentioned before in the forums, you may want to search for that to see if it will work for you.

    I believe there are settings for excluding "portfolio" category in the theme options as well.

    If you come up with a good solution let us know!

  5. buggsahoo
    Member
    Posted 1 year ago #

    Thanks Redwren!! IT WORKED... but...
    - I changed the template to "portfolio" for the page that will act as a blog.
    - I added a category for the post that I want to appear on the "blog" page
    - I added two posts and associated them with the new category
    - went to APPEARANCE->THEME OPTIONS->GENERAL then scrolled down and next to Portfolio Category I selected the "category" I wanted to appear on the "portfolio" theme page and SAVE

    It worked, but now my posts which are "standard" posts only show the title and not the full post, even though I have "Full posts to display on first page" set to "1".

    Here is the link to the page (I hope you can see it).
    blog page

    Why are my post not displaying the full post??

  6. paul.a.cunn
    Member
    Posted 1 year ago #

    Ok so you have several issues and I will try to address them all.

    To hide the slider images from all post pages other than on the slider: Add a category call it something like "Sliders" or "Slider images" Then in each of your slider posts mark them as being inside this category. Then go to "Appearance-> Theme OPtions -> General and under Portfolio Category select "Sliders." and put a 0 in both of the other boxes under this title. Then in the same area under "Home Page" Check the box that says "Exclude Portfolio from main loop" This should hide your slider images everywhere.

    To Hide posts from your home page but not on your secondary pages:
    Download the plugin "WP hide posts" this is what most people use to hide there posts in certain places. When you activate this plugin you will be able to hide the posts from pretty much everywhere. This option will be a new option when you are editing your posts on the right hand side.

    Hope this helps.

    Cheers!

  7. buggsahoo
    Member
    Posted 1 year ago #

    Plug-in had no affect on making the full post display. I even went to my settings and made some changes there, but still it did not work. Maybe I need to start another inquiry with the title of How to get my full post to show on the "portfolio" template.

  8. denieuwe30er
    Member
    Posted 10 months ago #

    the easiest way for me was:
    1) add an extra category to your posts, for example name it "blog", except for the posts that you use to show your sliders.
    2) add a menu item by using Links : url #, name Articles, Magazine or Blog or whatever you want (I wanted something different than blog).
    3) add a submenu item underneath your Link menu item, using categories: take the new category in my example "blog".

    Now it shows all your blog items (if you continue to add the extra category to your new posts) except the ones in the slider.

    Okay.. when you have a few hundred blogs..than maybe try something else..but it's worth the one time set up.

  9. wdwman
    Member
    Posted 10 months ago #

    I found a solution that worked for me, in the form of a slight code adjustment to Pinboard's index.php file, in a discussion on the Pinboard template designer's site.

    http://www.onedesigns.com/support/topic/remove-slider-from-blog-page-2

    There are many index.php files in my WordPress site, so make sure you edit the one in wp-content > themes > pinboard. Or do the edit using Appearance > Editor in the WordPress dashboard so that you edit the right one.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic