WordPress.org

Ready to get started?Download WordPress

Forums

Pinboard
[resolved] Pinboard - can't disable mobile, can't navigate Classic (5 posts)

  1. 1531bkt
    Member
    Posted 10 months ago #

    Have Pinboard theme.

    I tried to stop my site from defaulting to a mobile version when loaded on smartphones. My theme does not have an option under Appearance to disable mobile, so I followed steps to remove the '...viewport...' line in my header.php, outlined in the following forum, but it also did not work: http://wordpress.org/support/topic/pinboard-theme-not-working-in-mobile?replies=5

    I've tried deleting browsing data on my smartphone and reloading my site, but it keeps going back to the mobile version.

    Additional issue: When I scroll down to the bottom of the mobile view on a smartphone and select Classic, it loads my home page wonderfully to look like the desktop view. However, from that desktop view, clicking on any link doesn't work, as it tries to take me to a mobile site again and it winds up on dudamobile to tell me the page cannot be found. So even if my readers decided to manually get to my Classic view, they wouldn't be able to navigate my site.

    So 1) How do I permanently disable mobile rerouting? If I can't permanently disable mobile view, how can my readers navigate my site if they end up getting to my desktop view by clicking on Classic?

    I prefer the first option of permanently disabling mobile.

    My site is http://www.writingwithchopsticks.com. Thanks in advance.

  2. WPyogi
    Volunteer Moderator
    Posted 10 months ago #

    "Classic" is JetPack mobile - try turning that off.

    Where are you getting dudamobile from? A plugin or hosting option?

  3. 1531bkt
    Member
    Posted 10 months ago #

    Thanks. I disabled JetPack in my plugins (although I never activated JetPack before). Not sure where dudamobile is coming from, but I went ahead and disabled the plugins automatically uploaded via my host (godaddy). Essentially, the only plugins I have now are a contact plugin and a facebook plugin.

    Tried the site on my phone, and it's still defaulting to mobile redirect, and it's still presenting the option to go to Classic. Going to Classic and clicking on other links is still taking me to dudamobile page not found message.

    Sigh...

  4. 1531bkt
    Member
    Posted 10 months ago #

    Eureka! Figured it out. Went to my hosting acct thru godaddy, and turns out that I can disable mobile site there thru Hosting Details. That solved everything.

    Thanks for helping me get there!

  5. kellywirht
    Member
    Posted 1 month ago #

    i'm having the same issue! i just disable the mobile site via GoDaddy hosting. How long did it take before your phone stopped redirecting to the mobile subdomain?

Reply

You must log in to post.

About this Theme

About this Topic