WordPress.org

Ready to get started?Download WordPress

Forums

Pinboard
Pinboard and Carousel (Jetpack) (15 posts)

  1. gstoelen
    Member
    Posted 1 year ago #

    I installed Jetpack and I can't seem to use Carousel as image gallery in this theme. Been trying other themes and they don't have problems with Carousel :/

    It seems that whatever I adjust, Pinboard will always either use lightbox, or else it just shows the image in an attachment page :( Did any of you succeed in using Carousel in Pinboard ? And if so... how ? :)

    Cheers !

  2. Jeremy Herve
    Happiness Engineer
    Posted 1 year ago #

    Such problems can happen when your theme or one of your plugins makes changes to WordPress' Gallery shortcodes.

    Could you try to disable all other image and gallery plugins on your site?
    If it doesn't help, try switching to a different theme like Twenty Twelve for a few minutes: if the carousel starts working, your theme might be editing the Gallery shortcodes.

    If you do not find any functions that may alter the gallery shortcodes, you can also make sure that your theme's footer.php file includes the wp_footer function.

    Let me know if this helps.

  3. gstoelen
    Member
    Posted 1 year ago #

    Well it seems to be theme connected though ... Other themes work just fine with Carousel .. I would just like to know how I can make it work, using Pinboard :)

    Cheers

  4. Daniel Tara
    Member
    Theme Author

    Posted 1 year ago #

    Try to disable the lightbox from theme options. If it still doesn't work add this line at the end of functions.php:

    remove_filter( 'post_gallery', 'pinboard_gallery_shortcode' );
  5. Jeremy Herve
    Happiness Engineer
    Posted 1 year ago #

    Can you contact the theme author, and let them know about the issue? If you give them the link to this thread, they might be able to help you fix the issue based on my recommendations.

    Edit: Nevermind, Daniel is faster than me :)

  6. willw9
    Member
    Posted 1 year ago #

    Daniel:

    Can't get this to work for the life of me. Disabled plugins, disabled Lightbox, added in your code to the functions.php file, yet nothing happens. The images display in the original rudimentary grid when inserted as a gallery, and if clicked, link to either the attachment page or their own separate page with the image title, etc. In Settings-->Media, I just have the option of Black/White background, and Insert/Don't Insert EXIF data.

    How should I proceed?

  7. paul.a.cunn
    Member
    Posted 1 year ago #

    So jetpack has a known bug if you have WP 3.5.1. If you are trying to get the gallery to open as a light box instead of having it go to the attachment page just add link="file" to the short code. So the short code looks like the following.

    [gallery ids="1,2,3,4" link="file"]

    Hope this helps!

  8. willw9
    Member
    Posted 1 year ago #

    Anybody get this to work? Still cannot figure it out for the life of me.

  9. Jeremy Herve
    Happiness Engineer
    Posted 1 year ago #

    @willw9 Try installing this plugin on your site to remode Pinboard's custom gallery:
    http://i.wpne.ws/PDjq

  10. tanster
    Member
    Posted 1 year ago #

    I'm having the same problems as willw9.

    I have no other gallery plugins, disabled Pinboard's lightbox option, activated Jeremy's plugin, but it still won't bring up Carousel when using the Pinboard theme.

    If I switch to a different theme, such as Twenty Eleven, Carousel works just fine.

    My page:
    http://hannibalcafe.com/hannibal-savoureux-photos/

    Thanks!
    tanster

  11. Jeremy Herve
    Happiness Engineer
    Posted 1 year ago #

    Could you try adding this line at the end of your child theme's functions.php file?
    remove_filter( 'post_gallery', 'pinboard_gallery_shortcode' );

  12. tanster
    Member
    Posted 1 year ago #

    Hi Jeremy,

    I tried adding that to the end of my child theme's functions.php file, but that didn't work.

    So I ended up adding it to the end of the parent theme's functions.php file -- that worked beautifully!

    I know I'm not supposed to edit the parent theme's functions.php file -- I'll just have to remember to not override it the next time Pinboard comes out with an update. ;)

    My page now works correctly:
    http://hannibalcafe.com/hannibal-savoureux-photos/

    Thanks so much for your help!
    tanster

  13. fish911
    Member
    Posted 9 months ago #

    I apologize if this is off topic or should be placed in a new thread but I'm having the exact same problem but I'm using the zAlive theme.

    If someone could direct me on how to adjust this code to use on the zalive theme I would greatly appreciate it.

    remove_filter( 'post_gallery', 'pinboard_gallery_shortcode' );

  14. WPyogi
    Volunteer Moderator
    Posted 9 months ago #

    @fish911 - yes, this thread is totally irrelevant to your issue - not the same theme and 8 months outdated. - you need to ask on your theme's own forum:

    http://wordpress.org/support/theme/zalive#postform

  15. fish911
    Member
    Posted 9 months ago #

    Sorry to all for any inconvenience. Topic will be re-posted.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic