WordPress.org

Ready to get started?Download WordPress

Forums

Share Buttons by AddToAny
[resolved] Pin It button not working correctly (8 posts)

  1. WatkinsT
    Member
    Posted 3 months ago #

    Hello, my website just launched and my social sharing buttons are all working fine, except the "pin it" button. I tried delete and re-installing, but that did not help.

    When you hit the button it does not immediately take you to the "pin it" section on Pinterest, but to a page that has some of my photos, ads, etc. Can you please help? Thank you.

    tinseltownmom.com

    https://wordpress.org/plugins/add-to-any/

  2. micropat
    Member
    Plugin Author

    Posted 3 months ago #

    It seems to be working actually. The Pinterest tool loads instantly within your site's current page and offers the expected photos to pin.

    Try a different web browser and/or device. Usually it's some web browser add-on blocking content such as Pinterest widgets, etc.

  3. WatkinsT
    Member
    Posted 3 months ago #

    Hello, I just installed Chrome and got the same issue, and also same problem using my iPhone. When I hit the Pin button it takes me to a page with multiple photos, and some of my ads and I have to find the photo to select. In some cases the photo will not even appear. It should take me straight to the small pop up box, and allow a quick pin.

    Also, on some posts when I hit the Like or G+ button it will show a completely different photo, and I have to sometimes remove the photo and manually add the correct photo from my desktop. I look forward to hearing from you. Thank you.

  4. micropat
    Member
    Plugin Author

    Posted 3 months ago #

    Now I see. AddToAny is working as expected, but I can point you in the right direction:

    Check out AddToAny's FAQ on Facebook sharing because it applies to Pinterest and G+, too:
    "For Facebook sharing, how can I set the thumbnail image and description Facebook uses?"
    https://wordpress.org/plugins/add-to-any/faq/

    Testing your URLs with Facebook's debugger will show you what those services see for thumbnails:
    https://developers.facebook.com/tools/debug/

    Usually the "WordPress SEO" plugin can set the appropriate "open graph" tags to fix this site issue. Good luck!

  5. WatkinsT
    Member
    Posted 3 months ago #

    I will try it. Thank you.

  6. WatkinsT
    Member
    Posted 3 months ago #

    Hello, I just disabled the "like" button and added the basic Facebook button. I couldn't seem to get it working. Last question regarding the Pinterest button. What solution do you recommend? Currently, if I hit "pin it" from this device or another device I'm taken to a page with a lot of pictures and have to select from those photos as to what image I want to pin.

  7. micropat
    Member
    Plugin Author

    Posted 3 months ago #

    That's how Pinterest's pinner works — it gives the end-user the choice. It's different than most other services which try to select the one best thumbnail.

  8. WatkinsT
    Member
    Posted 3 months ago #

    So, is that something new with Pinterest? When I pin from other sites it takes be directly to where I want to pin. It doesn't give me a full page of photos to select from??

Reply

You must log in to post.

About this Plugin

About this Topic

Tags