WordPress.org

Ready to get started?Download WordPress

Forums

jQuery Pin It Button For Images
[resolved] pin it button doesn't show up (18 posts)

  1. yireservation
    Member
    Posted 6 months ago #

    Hi, thanks for this great plugin. I just installed the plugin but unfortunately I have not been able to get the pin it button to show on any of my images. Please help.

    My site is http://yireservation.com

    thanks

    http://wordpress.org/plugins/jquery-pin-it-button-for-images/

  2. mrsztuczkens
    Member
    Plugin Author

    Posted 6 months ago #

    Hi, your website doesn't use jQuery Pin It Button For Images plugin, so I can't help you.

  3. yireservation
    Member
    Posted 6 months ago #

    Hi, i am sorry could you be more specific. I have the plugin installed. Do I need to install something else in order to use your plugin? Thanks

  4. mrsztuczkens
    Member
    Plugin Author

    Posted 6 months ago #

    You're using a plugin named "Pinterest Pin It Button For Images", not "jQuery Pin It Button For Images" (which this forum is about). You are at the wrong support forum ;)

  5. yireservation
    Member
    Posted 6 months ago #

    Hi, I had both plugins installed but I just deleted the other one. I should only have "jQuery Pin It Button For Images" installed now but the pin it button still doesn't show up. Could you please help? Thanks.

  6. mrsztuczkens
    Member
    Plugin Author

    Posted 6 months ago #

    Hi again, I've checked your website again and am pretty sure the jQuery Pin It Button For Images plugin still isn't active.

  7. yireservation
    Member
    Posted 6 months ago #

    hi, I just de-activated and re-activated the plugin. Do you see the plugin now? I took a few screenshots. You can find them here and here. Could you please help. Thanks!

  8. mrsztuczkens
    Member
    Plugin Author

    Posted 6 months ago #

    Honestly, still nothing. Do you use some kind of fancy caching mechanism or maybe the URL address isn't right?

  9. yireservation
    Member
    Posted 6 months ago #

    That's really strange. I am not using any special caching tool. I am running on the thesis theme if that makes a difference. Please try this url: http://yireservation.com/. Thanks

  10. mrsztuczkens
    Member
    Plugin Author

    Posted 6 months ago #

    Here's a piece of source code of your website:
    <script type='text/javascript' src='http://yireservation.com/wp-content/plugins/pinterest-pin-it-button-for-images/ppibfi_pinterest.js?ver=3.6.1'></script>. According to it, there's the Pinterest Pin It Button for Images plugin running on your website.

  11. yireservation
    Member
    Posted 6 months ago #

    could you check again, that source code didn't exist when I just serached for it but I do see this: http://yireservation.com/wp-content/plugins/jquery-pin-it-button-for-images/css/style.css?ver=1.11' type='text/css' media='all' />

  12. mrsztuczkens
    Member
    Plugin Author

    Posted 6 months ago #

    Ok, now I can see the plugin. Please enable debug mode in plugin's settings (advanced).

    One more thing - the source code of your website is a little bit messy. It includes the jQuery library 3 times (in 3 different versions) what might cause some issues with plugins (including mine). It would be cool if you could do something about it.

  13. yireservation
    Member
    Posted 6 months ago #

    ok thanks. I have enabled the debug mode. will look into the source code of my site.

  14. mrsztuczkens
    Member
    Plugin Author

    Posted 6 months ago #

    Two things:
    1. Debug mode doesn't seem to be enabled ("debug":"0" in the source code of the website)
    2. There are a couple of JavaScript errors when your website loads, they might be the reason the plugin doesn't work.

  15. yireservation
    Member
    Posted 6 months ago #

    Hi, I just checked and I confirm that the debug mode has been enabled. Could you please be a little more specific on the java script error. I really would like to make the plugin work on my site. Thanks again.

  16. mrsztuczkens
    Member
    Plugin Author

    Posted 6 months ago #

    Ok, the debug mode is on and the website doesn't output any messages in the console, therefore I know the code from my plugin isn't even executed.

    I'm 99% sure it's because of the JavaScript errors on the site. It seems that you don't know much about JavaScript etc, so my advice for you is to ask someone to help you fixing those errors.

  17. yireservation
    Member
    Posted 6 months ago #

    Thanks a lot for your help. I'll try to find someone to help me.

  18. mrsztuczkens
    Member
    Plugin Author

    Posted 6 months ago #

    You're welcome.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.