WordPress.org

Ready to get started?Download WordPress

Forums

Pilcrow
Pilcrow Causing Site To Be Slow? (17 posts)

  1. kathrinejoy
    Member
    Posted 6 months ago #

    Hi. This is my site: http://www.motleymama.com

    I've been using pilcrow for two years now and recently my site has been loading very slowly or timing out all together. Bluehost (my host) says it's a problem with my theme. I have customized it but I think I've done it right? Any help?

  2. batharoy
    Member
    Posted 6 months ago #

    Your host would almost never admit that it's something on their end. ;)
    That being said, I just visited your site in 4 different browser and all of them completed rendering of the home page within 3-6 seconds.
    Is there a particular page that's going slow?

  3. kathrinejoy
    Member
    Posted 6 months ago #

    Bluehost and I have been in a fight for about 3 months now :)

    You're right, the pages load fast until all of a sudden they don't. I'll be working on a post in my dashboard or randomly clicking on my site and all of a sudden the site will "crash." It says it's lost connection. So weird. I've read a lot about how many it's because I've tried to customize my theme.

  4. Hi there - your site loaded quite fast for me - I'm pretty sure it's not the theme. :-)

    You can try a traceroute to your domain to see if there's network trouble along the way from your machine to the host:

    http://en.support.wordpress.com/browser-issues/advanced-browser-troubleshooting

    Instead of a traceroute to s0.wp.com do one to www.motleymama.com

    If you really want to rule out the theme, try switching themes temporarily.

    It says it's lost connection.

    That probably indicates some kind of network problem, either at your end or your host's end. Have you tried your site from another location?

  5. Bluehost (my host) says it's a problem with my theme.

    I would ask to speak with another support rep. That's not an adequate reply.

  6. batharoy
    Member
    Posted 6 months ago #

    because I've tried to customize my theme.

    If that were true almost every WP site would be slow.

    I turned off my ad-block and browsed around on every page and different posts. The only thing I found wrong is the 1st youtube vid on homepage. The user deleted their account and it's no longer there.

    I did however notice it looks like you don't use a child-theme or a css plugin, is that correct?

  7. kathrinejoy
    Member
    Posted 6 months ago #

    Right. No child theme or css plugin.

  8. kathrinejoy
    Member
    Posted 6 months ago #

    Edited

  9. batharoy
    Member
    Posted 6 months ago #

    Any custom edits you have made will be erased if the theme is ever updated.
    I would recommend using one or the other. If its just css changes you can activate the custom css module in jetpack.
    If however there are php custom edits, you will need to create a child-theme.

  10. kathrinejoy
    Member
    Posted 6 months ago #

    I'm using the css module in jetpack. Which did decrease the times of lost connectivity. But it's still happening daily.

  11. Thanks for passing that along. First off, caching, plugins, and Jetpack are not theme-related issues. :-)

    You have a ton of database errors in your logs:

    WordPress database error Lost connection to MySQL server
    WordPress database error MySQL server has gone away

    Database connection errors could certainly cause the issues you describe with your site timing out.

    They are not caused by a particular theme.

    You may want to think about reinstalling WordPress from a fresh copy after ruling out other issues. To rule out other issues:

    - try a default theme temporarily
    - try turning off all plugins temporarily
    - try a traceroute as I mentioned above.

    I also suggest you remove that error log from the public folder as it could be a security risk to expose it publicly like that.

  12. kathrinejoy
    Member
    Posted 6 months ago #

    Thank you. I removed it!

    I have reinstalled WP so many times (through the dashboard under updates).

    I tried a default theme (wordpress 2013) but it still happened. Disable all plugins? Then just see what happens?

    I will try a traceroute now. Thank you!

  13. I tried a default theme (wordpress 2013) but it still happened. Disable all plugins? Then just see what happens?

    If the problem goes away after deactivating all plugins, reactivate them one by one, checking your site in between each to see if the problem comes back. When it does, the last-activated plugin is the likely culprit.

  14. kathrinejoy
    Member
    Posted 6 months ago #

    Traceroute has started…

    traceroute: Warning: http://www.motleymama.com has multiple addresses; using 108.162.198.70
    traceroute to cf-protected-www.motleymama.com.cdn.cloudflare.net (108.162.198.70), 64 hops max, 72 byte packets
    1 wireless_broadband_router (192.168.1.1) 0.621 ms 0.386 ms 0.349 ms
    2 l100.hrbgpa-vfttp-16.verizon-gni.net (98.117.6.1) 7.467 ms 7.543 ms 9.684 ms
    3 g9-0-2-216.hrbgpa-lcr-02.verizon-gni.net (130.81.139.134) 7.499 ms 7.281 ms 7.418 ms
    4 so-12-1-0-0.res-bb-rtr1.verizon-gni.net (130.81.28.254) 19.948 ms 19.606 ms 20.022 ms
    5 0.xe-4-1-0.br2.iad8.alter.net (152.63.38.153) 19.944 ms 21.864 ms 20.025 ms
    6 ae-20.r04.asbnva02.us.bb.gin.ntt.net (129.250.8.33) 50.398 ms 49.274 ms 50.411 ms
    7 xe-4-0-3.ar1.iad1.us.nlayer.net (69.31.31.32) 22.136 ms
    xe-4-0-6.ar2.iad1.us.nlayer.net (69.31.31.176) 22.599 ms *
    8 ae0-30g.ar1.iad1.us.nlayer.net (69.31.31.133) 22.090 ms 22.480 ms
    as13335.xe-7-0-3.ar1.iad1.us.nlayer.net (69.31.31.90) 19.989 ms
    9 108.162.198.70 (108.162.198.70) 19.729 ms 19.453 ms 19.955 ms

  15. traceroute to cf-protected-www.motleymama.com.cdn.cloudflare.net

    You are using CloudFlare? Try turning it off and see if the problems go away.

  16. kathrinejoy
    Member
    Posted 6 months ago #

    Bluehost installed Cloudflare to "help" with the problem.

  17. Then I'd definitely try the plugin route next. See my instructions above.

Reply

You must log in to post.

About this Theme

About this Topic

Tags