WordPress.org

Ready to get started?Download WordPress

Forums

phpMyAdmin wp_users won't change (10 posts)

  1. Nekkid_Fish
    Member
    Posted 8 years ago #

    I posted a question about username/password no longer working, a long time ago ... and it has now happened again.

    I tried the new fix I found searching here ... at http://www.tamba2.org.uk/wordpress/phpmyadmin/ but that didn't work.

    When I get to the last step, my string of letters and numbers (password) doesn't change when I hit Go. Is this a problem with phpMyAdmin that I need to email my host about?

    In the past, the old fix was to go to some website that created a new string of letters and numbers to create a new password, but I've searched and cannot find that solution.

    I think I am using an older version of Word Press (maybe 1.2, and I'm not sure if that is the issue or what.

    Any and all help will be greatly appreciated.

    HUGz! Jules

  2. vkaryl
    Member
    Posted 8 years ago #

    You really need to know which version you're using. If it's as far back as 1.2, you really should upgrade....

    You should be able to see what version you're using in your admin section.

  3. Nekkid_Fish
    Member
    Posted 8 years ago #

    I hate to sound stoopid, but is it hard to upgrade?

    My host initially installed it for me, as I wasn't sure how to do it ... although I have gotten better at understanding how databases work.

    Are there any problems I should know about ahead of time before upgrading?

    Thanks bunches! Jules

  4. vkaryl
    Member
    Posted 8 years ago #

    Well, you have to upgrade incrementally. From 1.2+ you have to go first to 1.5.2, then to 2.0.2.

    Does your host still do this sort of thing for you?

  5. Nekkid_Fish
    Member
    Posted 8 years ago #

    I don't know, I'll have to ask.

    If not, is it hard to do?

    Thanks! Jules

    P.S. Is the old option that I mentioned, on getting a new password not an option any more? That would be easiest, as otherwise the blog works fine.

  6. davidchait
    Member
    Posted 8 years ago #

    yes, the wp-login form has an option to recover a lost password to the email account on file.

    also, phpMyAdmin not working could be an issue with your host. I know Site5 right now has problems if you log into phpMyAdmin through the my.site5 control panel, but there's a way to directly log-in that will allow field updates properly.

    -d

  7. Nekkid_Fish
    Member
    Posted 8 years ago #

    Thanks David. Sorry I hadn't responded, but I've been sick.

    I have submitted a support ticket to HostingMatters, asking if there's a problem.

    Can I also ask, regarding the new fix, it talks about going into the 'cache' directory and deleting anything in there.

    When I went into my wp-content, there isn't a file just called 'cache', but 2 files called 'link-update-cache.xml' and 'links-update-cache/xml'. But there is nothing in these files ... they look empty to me.

    Am I supposed to delete those two files before I make the password change in the phpMyAdmin?

    Thanks and HUGz! Jules

  8. Nekkid_Fish
    Member
    Posted 8 years ago #

    Oh and regarding "yes, the wp-login form has an option to recover a lost password to the email account on file."

    If I click on 'forgot password' and put in my username and email address ... I get an email with my username and a new numeric password.

    However, when I try to log in with my username and the new password, that doesn't not work either.

    Thanks! Jules

  9. Nekkid_Fish
    Member
    Posted 8 years ago #

    Well, no luck from my hosting company yet ... here's what I just got from them:

    "Jules,

    I'm not sure why this isn't working, as it's the correct syntax for changing the password.

    As you can see here it does:

    "SQL query: UPDATE wp_users SET user_pass = MD5( 'virtualw' ) WHERE ID =1 LIMIT 1 ;"

    That's the mySQL string that updates the password, It went through no problem.

    I'm going to forward this to an Administrator to see if they can offer any suggestions for this."

    Hopefully I'll hear something positive back.

    HUGz! Jules

  10. Nekkid_Fish
    Member
    Posted 8 years ago #

    Well, maybe ya'll can add this to your database of WordPress problems -- for others that might experience this problem with their MyphpAdmin.

    After reading here for hours, I found this:

    I went into my wp-config.php file and added the following line:

    define('DISABLE_CACHE', true);

    I then scrolled to the bottom of the string and hit the back space key, as it added an extra space.

    I then saved that file.

    I then went into MySQL to the database, and followed the directions from the link I posted about earlier.

    I can now log in.

    Sheesh! This, along with a killer cold! :rolleyes:

    Glad it's almost TGIF!

    HUGz! Jules

Topic Closed

This topic has been closed to new replies.

About this Topic