WordPress.org

Ready to get started?Download WordPress

Forums

PHP5 support (7 posts)

  1. mailnov
    Member
    Posted 6 years ago #

    I am evaluating WordPress and got a hard stop by the requirements: WP requires PHP 4.3 although Support for PHP 4 has been discontinued since 2007-12-31. Please consider upgrading to PHP 5.2.

    Looking at the forums, it seems that PHP5 is causing issues with WP which does not surprise me (I have a self-developed PHP application which I had to make PHP5 compliant; it's doable but requires some efforts).

    It is a security risk to run an application on an unsupported PHP stack

    What are the plans for PHP5?

  2. Lester Chan
    Member
    Posted 6 years ago #

    PHP5 causing problems for WP?

  3. mailnov
    Member
    Posted 6 years ago #

    This is what I was reading out of the forums. - I have not yet installed WP. I am in the planning phase.

  4. whooami
    Member
    Posted 6 years ago #

    wordpress has NO problems with PHP5 -- or vice versa.

  5. Lester Chan
    Member
    Posted 6 years ago #

    I have been on PHP5 with WP for a few years and no problems.

  6. whooami
    Member
    Posted 6 years ago #

    as have countless others. :P
    .
    I migrated my own blog that was working flawlessly on PHP4, to PHP5 a few months back, without a single issue. Not one.

  7. NC@WP
    Member
    Posted 6 years ago #

    mailnov,

    I am evaluating WordPress and got a hard stop by the requirements: WP requires PHP 4.3

    Where the heck have you read that? The requirements page clearly says, 4.3 or greater. WordPress itself is completely oblivious to any and all differences between PHP 4 and PHP 5... This said, there may be some third-party extensions (themes, plugins, etc.) that use object-oriented programming and, therefore, may be sensitive to PHP version...

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags