WordPress.org

Ready to get started?Download WordPress

Forums

WP Calendar
PHP warning messages and not able to create a category (8 posts)

  1. hauxton68
    Member
    Posted 9 months ago #

    Great plugin by the way - so firstly big thanks for the amazing work.

    I am using WP Calendar v1.5.3 on WP 3.6/1 (but was previously using 3.6 and 3.5.1 and all had same problem).

    When using Dashboard > calendar i get:

    Warning: Creating default object from empty value in /homepages/34/d474185196/htdocs/SWCClive/wp-content/plugins/wp-calendar/fsCalendarAdmin.php on line 367

    and when displaying an event in a simple list using {events_printlist;} or similar i get:

    Warning: Creating default object from empty value in /homepages/34/d474185196/htdocs/SWCClive/wp-content/plugins/wp-calendar/fsCalendarEvent.php on line 69

    I dont want to turn PHP warning messages off for various reasons.

    Do you know what the problem is?

    I cannot link to site as its on a dev server at the moment.

    http://wordpress.org/plugins/wp-calendar/

  2. kaduprey
    Member
    Posted 7 months ago #

    I had same problem re "default object" error messages. Found a solution after lots of googling...

    Error seems to be caused by:
    $evt->eventid = 0;
    It occurs in 3 places in the WP-Calendar plugin (version 1.5.3): twice in fsCalendarAdmin.php; once in fsCalendarEvent.php

    Solution:
    Add this line in the .PHP files just above the problematic code:
    $evt = new stdClass();
    ---------------------------
    Caveat emptor: I am not a programmer, and know just enough about code-hacking to be dangerous.

    As for the Category problem, I'm experiencing that too. My workaround is to add them in the Post Categories area & advise my WP clients to do the same.

    Hopefully these bugs will be fixed in the next version of WP Calendar.

  3. alexWP333
    Member
    Posted 5 months ago #

    I ran into the same problem too.

    kaduprey, I used the instructions that you posted, and it did remove the "fsCalendarEvent.php on line 69" warning that was appearing on my full calendar page. Many Thanks!

    However, when I go to view a Single Event page I'm still getting the "fsCalendarAdmin.php on line 376" warning.

    Would you hazard a guess as to what further hacking would remove this second warning?

    Alex

  4. DYC - The Voice Of Generation
    Member
    Posted 5 months ago #

    {Warning: Creating default object from empty value in }

    you need to open fsCalendarAdmin.php file and check blank space or white space in front of <?php

    sometimes this problem takes place and creates object from empty value.

  5. alexWP333
    Member
    Posted 5 months ago #

    Thanks DYC,

    I checked the fsCalendarAdmin.php, and there's no blank or white space before the <?php , and there's a return after the < ?php , like so:

    <?php
    class fsCalendarAdmin {
    
    	var $settings;
  6. dsg257
    Member
    Posted 4 months ago #

    Same problems here but the solution above did nothing but hide all me events in the calendar

  7. dsg257
    Member
    Posted 4 months ago #

    Right found the problem and the solution to the php 5.4 version
    I accidently upgraded php from 5.2 to 5.4 and messed up a few plugins
    I phone the host 1and 1 very helpful second time around I asked then to downgrade to 5.2 but my global php ver is 5.4
    what they did was change a setting in my .htaccess file
    I had the following

    AddType x-mapp-php5 .php
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    but she changed the first line to

    AddHandler x-mapp-php5 .php
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    when I went to my site and the phpinfo.php it shows
    php Version 5.2.17
    and everything working again ESPECIALLY this Plugin
    I use a lot of custom code for the calendar

  8. efebert
    Member
    Posted 4 months ago #

    Thanks,
    this worked for me, too.

Reply

You must log in to post.

About this Plugin

About this Topic