WordPress.org

Ready to get started?Download WordPress

Forums

amr ical events lists
[resolved] PHP Warning: call_user_func_array() amr_debug_time (9 posts)

  1. rayman5231
    Member
    Posted 9 months ago #

    amr_debug_time

    is this a valid function in your plug-in?

    possible conflict with BPS

    [21-Sep-2013 00:19:38 America/Los_Angeles] PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, function 'amr_debug_time' not found or invalid function name in /public_html/first-blog/wp-includes/plugin.php on line 406

    WP 3.6.1, Multisite

    many thanks

    http://wordpress.org/plugins/amr-ical-events-list/

  2. AITpro
    Member
    Posted 9 months ago #

    There is not a conflict with the BPS plugin. This is an isolated coding issue in the amr ical events lists plugin. The action/function probably just needs to be called in another way. PHP errors will tell you which plugin, theme, etc. has a coding issue that needs to be fixed and then you would fix that issue in that plugin, theme, etc.

    http://wordpress.org/support/topic/php-warning-call_user_func_array-amr_debug_time?replies=3

  3. rayman5231
    Member
    Posted 9 months ago #

    so like

    if in debug mode do this?
    if not in debug mode do that?

    Ann Marie? I really do not want to fiddle with your Code, but I can if need be. Please advise when you get a chance.
    Many thanks

  4. AITpro
    Member
    Posted 9 months ago #

    Since you mentioned you have a Network/Multisite site then I wonder if the issue is as simple as this:

    Maybe a check needs to be done for multisite and load the multisite action instead of the plugins_loaded action:

    if ( is_multisite() ) {
    add_action('muplugins_loaded', 'amr_debug_time');
    } else {
    add_action('plugins_loaded', 'amr_debug_time');
    }

    Network/Multisite specific function:
    http://codex.wordpress.org/Plugin_API/Action_Reference/muplugins_loaded

  5. AITpro
    Member
    Posted 9 months ago #

    An additional check for this condition might need to done as well, I think anyway? I did not really look too deep at the code in this plugin to see exactly what is occuring.

    http://codex.wordpress.org/Function_Reference/is_plugin_active_for_network

  6. rayman5231
    Member
    Posted 9 months ago #

    Will stop trying to confuse me with facts, jk

    so does the change have to be made in AMR's code or in PHP.INI or WP-settings.php?

    It's like who's CORE is this anyway?, Right?

    Just let me know when this is sorted out, but thanks for keeping me IN the LOOP, ok?

  7. AITpro
    Member
    Posted 9 months ago #

    Those were hints/possible solutions for this Plugin Author to try.

  8. anmari
    Member
    Plugin Author

    Posted 9 months ago #

    HI all,

    until an update goes up. Quick fix is comment out line 2370 (practically the last line) in amr-ical-events-list-main.php.

    The debug time function is non essential - a helper function for some folks whose ics file loads were timing out. Only used when debugging.

    // add_action('plugins_loaded', 'amr_debug_time');

    I will either remove it, or change to only run the add action if the GET debug parameter is passed.

  9. rayman5231
    Member
    Posted 9 months ago #

    Thank you I feel much better now. Temp fix in place.
    Really thanks all. Have a good weekend.

Reply

You must log in to post.

About this Plugin

About this Topic