WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] PHP notices (6 posts)

  1. mbiz
    Member
    Posted 1 year ago #

    Hi,

    Just to let you know.

    When activating WP debug mode I get these notices:

    NOTICE: wp-content/plugins/wordpress-https/lib/WordPressHTTPS/Url.php:502 - Undefined index: user
    NOTICE: wp-content/plugins/wordpress-https/lib/WordPressHTTPS/Url.php:502 - Undefined index: pass
    NOTICE: wp-content/plugins/wordpress-https/lib/WordPressHTTPS/Url.php:504 - Undefined index: port
    NOTICE: wp-content/plugins/wordpress-https/lib/WordPressHTTPS/Url.php:506 - Undefined index: query
    NOTICE: wp-content/plugins/wordpress-https/lib/WordPressHTTPS/Url.php:507 - Undefined index: fragment

    http://wordpress.org/extend/plugins/wordpress-https/

  2. Mvied
    Member
    Plugin Author

    Posted 12 months ago #

    Thanks, I'll clean these up.

  3. Danny Albeck
    Member
    Posted 7 months ago #

    I am also generating a ton of these errors. On WP 3.6.1 and WordPress HTTPS (SSL) 3.3.6

  4. Chirag Vora
    Member
    Posted 5 months ago #

    I am also getting these notices.

  5. esmi
    Theme Diva & Forum Moderator
    Posted 5 months ago #

    @chirag740: As per the Forum Welcome, please post your own topic.

  6. skillio
    Member
    Posted 1 month ago #

    I noticed this has long since been fixed in the github's Url.php.

    Mvied, could you please post an update to the official wordpress plugin containing the newer function? Anyone running the debug bar or equivalent gets these notices on every page.

    https://github.com/Mvied/Mvied/blob/master/Url.php line 484 has the updated fromString method that hasn't yet made its way into the wordpress plugin. Using this will get rid of your errors

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic