WordPress.org

Ready to get started?Download WordPress

Forums

Sucuri Security - Auditing, Malware Scanner and Hardening
[resolved] PHP memory_limit set to 2048m when plugin enabled (4 posts)

  1. doublesharp
    Member
    Posted 9 months ago #

    I noticed my site was allocating 2048m of memory to each PHP process, far greater than what I had specified in php.ini as my default and considerably greater than what I had set in this particular site's wp-config.php. Upon further investigation I found that the Sucuri plugin was setting @ini_set('memory_limit', '2048M');, but not just for some cases, any time the plugin was enabled. Is this by design? As it stands I have it commented out as it was causing issues when the server is under load.

    http://wordpress.org/plugins/sucuri-scanner/

  2. doublesharp
    Member
    Posted 9 months ago #

    I ran a 10 minute load test with the plugin enabled and disabled (no other changes), and processed 15,683 requests when it was enabled and 40,517 when it was disabled...

  3. brunoaborges
    Member
    Posted 8 months ago #

    Hi,

    Thanks for your message.
    This configuration will be changed in the future releases of our plugin.

    Regards,

    Bruno Borges
    [ Signature moderated. ]

  4. Yorman
    Member
    Plugin Author

    Posted 1 month ago #

    This was a featured copied from our premium plugin, we added an option in the settings page were you can configure the memory limit for the plugin when running the filesystem scans.

Reply

You must log in to post.

About this Plugin

About this Topic