WordPress.org

Ready to get started?Download WordPress

Forums

Embed iPhone/iPad App
[resolved] PHP Intl extension (9 posts)

  1. Aslan Guseinov
    Member
    Posted 1 year ago #

    Hi! I have a problem with my hosting provider. They don't want to add PHP Intl extension to my account. So how can i translate Embed iPhone/iPad App in to russian language?

    http://wordpress.org/extend/plugins/embed-iphoneipad-app/

  2. roomshare
    Member
    Plugin Author

    Posted 1 year ago #

    PHP Intl extension is only used for translations on few items, like country (Russia in English instead of RU, for example), language and currency.

    All other parts can be translated by adding .po and .mo file under languages/ sub-folder. For example, if Russian,

    language/embed_iphoneipad_app-ru.po
    language/embed_iphoneipad_app-ru.mo

    are needed. You may copy the current Japanese .po, rename 'ja' with 'ru', and edit .po file with appropriate translation tool such like PoEdit. PoEdit will create .mo from .po automatically when you save.

    If you send me the Russian po/mo files, I will include them and most texts will be display in Russian in Russian configuration.

  3. Aslan Guseinov
    Member
    Posted 1 year ago #

    I translated couple of words with poedit and saved it with names you specified. Uploaded files to folder where japanese .po and .mo located. And no changes is visible. You can see for your self http://appyramid.com/
    i translated words "Genre" and "Screenshots". What i'm doing wrong here? Sorry for my English. I'll post a link when i finish.

  4. roomshare
    Member
    Plugin Author

    Posted 1 year ago #

    When you change WPLANG in wp-config.php to 'ja', like,

    define('WPLANG', 'ja');

    are you seeing everything displayed in Japanese? If so, and if you do,

    define('WPLANG', 'ru');

    and your translations do not show up, it is likely that somethings are different between your -ru.mo and my -ja.mo files. Maybe folder/file ownership, group, permissions. It is also possible that your .mo file is not a proper mo file format by some reasons (which I can not guess from here though).

    I assume that some other Russian localized scripts are working on your box, right? If not, you need to check if your os has that locale installed.

  5. Aslan Guseinov
    Member
    Posted 1 year ago #

    Hi again! I downloaded latest version of WordPress 3.5.1 English version and made a clean insall. Then installed Embed iPhone/iPad App and made changes to wp-config.php file. When "define('WPLANG', 'ja');" everything is in english except the line "Language:", languages is shown in Japanese. Same thing with define('WPLANG', 'ru'); and "RU", "ru_RU". I even installed qTranslate, to try different options. When i make Japan default language it doesn't show translation. It is still in english. Don't know what else can i do.

  6. Aslan Guseinov
    Member
    Posted 1 year ago #

    The only way i can translate it, is to manualy edit EmbedIphoneIpadApp.php file.

  7. roomshare
    Member
    Plugin Author

    Posted 1 year ago #

    Let me check again which parts you want to be translated. "Genre:" or "Language:" should be translated with your .po/mo files. Language names (like English, Russian) are translated only when you set up php_intl extension.

    If you are seeing the English "Language:" even if WPLANG=ja, it is because your web server/PHP process can not open -ja.mo file. Please ease ownership/permissions on the mo/po files and the directories having those files.

  8. roomshare
    Member
    Plugin Author

    Posted 1 year ago #

    You may also send your -ru.mo file to siteadmin (at) roomshare.jp then I can check if the mo file is properly made on my local. (You do not have to translate all messages, just a few are enough for me to check.)

  9. roomshare
    Member
    Plugin Author

    Posted 1 year ago #

    By getting AslanDoma's (partially-translated) Russian resource file, there turned to be a bug which all translation did not work on the posts/pages. Translation only worked on admin panel.

    I updated the plugin to version 1.0.9 so now all non-English translations should work fine.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.