WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] PHP Fatal error: Out of memory in /wp-includes/wp-db.php (5 posts)

  1. sutdhar
    Member
    Posted 5 years ago #

    Please help me, I will be very thankful.
    I'm running latest version of WordPress 2.6.1 with wp-super-cache0.6.6.
    I've checked the site after deactivating all the plugins as well, but no luck, the problem still remains.

    My wordpress site http://www.sutdhar.com/ is creating PHP Fatal errors - error_log with entries something similar to the following erros messages:

    [16-Aug-2008 04:34:17] PHP Fatal error: Out of memory (allocated 30408704) (tried to allocate 745813 bytes) in /home/sutdhar/public_html/wp-includes/wp-db.php on line 429
    [16-Aug-2008 04:35:46] WordPress database error MySQL server has gone away for query UPDATE wp_options SET option_value =
    .
    .
    .
    [16-Aug-2008 04:35:46] WordPress database error MySQL server has gone away for query SELECT * FROM wp_posts, wp_postmeta WHERE wp_posts.ID = wp_postmeta.post_id AND wp_postmeta.meta_key = '_pingme' LIMIT 1 made by do_all_pings
    [16-Aug-2008 04:35:46] WordPress database error MySQL server has gone away for query SELECT * FROM wp_posts, wp_postmeta WHERE wp_posts.ID = wp_postmeta.post_id AND wp_postmeta.meta_key = '_encloseme' LIMIT 1 made by do_all_pings
    [16-Aug-2008 04:35:46] WordPress database error MySQL server has gone away for query SELECT ID FROM wp_posts WHERE to_ping <> '' AND post_status = 'publish' made by do_all_pings

  2. sutdhar
    Member
    Posted 5 years ago #

    thanks GOD

    my problem is resolved :-)

    I solved it myself, ofcourse using googling!!!

    I'm posting here the solution to help others as well for similar problem.

    Problem was in the wordpress database table - wp_options

    Search for cron in column - option_name of table - wp_options

    Search may return 5-10 results( can be less or more )

    Now look for entry something similar to - a:112:{i:1218988914;a:1:{s:8:"do_pings";a:1:{s:32:... in column - option_value of table - wp_options

    Solution: Change this strange option_value entry to 0

    That's it, problem solved. All will works fine now.

    Please say thanks to me, if this solves your problem as well.

    Bye for now.

    Take care.

    :)

  3. happyches
    Member
    Posted 5 years ago #

    Made no difference to me unfortunately..

    But thanks for posting, hopefully it helps someone else. :)

    (I had a "twitterdoodle" plugin with ping options in the Cron above, but changing the value to 0 made no difference.)

  4. celebritydaddy
    Member
    Posted 5 years ago #

    Hello,
    would this fix my problem?

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 44 bytes) in /home/celeb321/public_html/wp-includes/wp-db.php on line 814

    Where is the "wordpress database table"?

    Thanks!

  5. shunyata
    Member
    Posted 5 years ago #

    I am having same problem. any other solution?

Topic Closed

This topic has been closed to new replies.

About this Topic