WordPress.org

Ready to get started?Download WordPress

Forums

PHP Fatal error: Maximum execution time of 30 seconds (34 posts)

  1. kateh
    Member
    Posted 2 years ago #

    hi - today i started to get the following message on and off all day:
    PHP Fatal error: Maximum execution time of 30 seconds .... the rest of the line can refer to any number of pages, posts, plugins, jetpack etc - not related to where i am trying go as far as i can see.
    now the site is working again .... but it keeps coming and going - one minute it is there and the next gone!
    help please - how do i sort it
    cheers

  2. ce_kevinw
    Member
    Posted 2 years ago #

    Hi kateh,

    If you're site is taking longer than 30 seconds, it could be:

    1. A plugin stuck in some sort of bad login / loop. Try disabling all plugins, and if it resolves the issue, enable them one by one to determine which one is causing the problem.

    2. Your host could be experiencing a problem on their end. For example, you most likely share a server with other users. If another user has a MySQL query taking 30+ seconds to run, then your WordPress script can time out waiting for its turn to run queries.

    3. It could also be something theme specific. Try enabling the default WordPress theme to see if this helps.

    Good luck, keep us updated!

  3. kateh
    Member
    Posted 2 years ago #

    thank you so much for the suggestions - will get on to the plugins now, and will call my web host tomorrow to talk to them about the sql query possibility. thanks thanks - and i'll report back :-) cheers k

  4. kateh
    Member
    Posted 2 years ago #

    hi again - ok - disabled all the plugins but it is still happening, took off some widgets that i'd recently added as well (scoop.it profile etc)... still not sorting the issue.
    web host says they arent having any problems - nothing reported from anyone else.
    last step is to try the default theme and will see what difference that makes
    cheers

  5. kateh
    Member
    Posted 2 years ago #

    Could it be a jetpack issue? I tried disabling all the plugins and then could not get jetpack to start back up again: so I deleted wordpress.com stats which was sitting in the Inactive folder just in case that was the problem, but I am still getting:

    Jetpack could not contact WordPress.com: register_http_request_failed. This usually means something is incorrectly configured on your web host. There are no HTTP transports available which can complete the requested request.

    My webhost says no they think it is a wordpress problem, and going by the threads online it does seem that it could be. For the moment i have deactivated JetPack and so have no stats package (which was all i needed it for anyway).

    and - crossing fingers - have not had a timeout error when trying to access my blog today! (though i think this may just be a coincidence :-)

    cheers
    k

  6. kateh
    Member
    Posted 2 years ago #

    it was a coincidence .... all started up again

  7. esmi
    Forum Moderator
    Posted 2 years ago #

    Have you tried:

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  8. kateh
    Member
    Posted 2 years ago #

    CHEERS - will try that in the morning (am too scared to change themes at the moment cos everything is timing out and i'm concerned i might loose stuff.... but in the mornings everything seems to run more smoothly :-) --- i'm thinking cos less internet traffic until america wakes (i'm in scotland :-). so yep will try that tomorrow.
    and will have a look at the resetting the plugins folder now.
    thanks thanks

  9. kateh
    Member
    Posted 2 years ago #

    did the resetting plugins thing but not making any difference so far.
    will try the theme suggestions in the morning
    thanks

  10. Oleg Dudkin
    Member
    Posted 2 years ago #

    Do you have access to hosting settings?
    Can you view server load?
    It seems like some sort of error on server. Can you contact hosting support?
    If error comes up suddenly - it is not wordpress issue.

    To aviod data loss.
    Backup database. Use hosting web panel for it (if any) or upload phpMyAdmin to server to make backup manually. Or use some of free googlable scripts.

    When running site measure time it takes site to load. Reload the same page several times.

    Find some file on server, for example image from theme, and try to load it from different browsers severals times. Turn browser cache off.
    If image downloading time differs a lot - it is server issue.

    Or just post your site URL here ))

  11. kateh
    Member
    Posted 2 years ago #

    Hi Oleg - thanks for the suggestions
    I've been in touch with my web hosts and they dont think it is server load cos i'm on a shared server and there are no problems with anyone's else's site that are on that server, however they are going away to have a cloaser look.
    I've now taken off all plugins and activated the wordpress default theme (so everything now looks AWFUL :-)) http://enf.org.uk/blog/ (the theme i had been using was mystique)

    two points that might be of use:
    the main bit of the site http://www.enf.org.uk doesnt seem to be affected, it is always the blog.
    the php error message only starts to happen early afternoon (and then all afternoon and at least early evening).... for some reason i dont have any problems in the morning.

    So - i'm presuming i cant tell whether it is a theme issue until later this afternoon... so have to leave the default theme on for a while.

    Question: i'm hosted on a windows server (cos the main site has a backend from where i send newsletters and the database it runs on only works in a Windows environment) .... would it help if i moved the blog on to a Linux server?

    whoa

    thanks everyone
    kate

  12. Oleg Dudkin
    Member
    Posted 2 years ago #

    Generally, linux hostings are better. But it shouldn't make so much difference.

    Also, I think it's better to switch back to your normal theme and wait untill (if) errors appear. And then switch to default theme to see if it fixes problem.

  13. kateh
    Member
    Posted 2 years ago #

    ah ok - good plan
    will activate the old theme and then do as you suggest...cheers

  14. kateh
    Member
    Posted 2 years ago #

    aargh they updated my old theme Mystique and now i cant get the old one back ... well i can get it but everything is blank.... now beginning to think maybe the old mystique was just too resource heavy??
    now installed Ari --- which isnt quite perfect for me but a hell of a lot better than the default or mystique-lite.
    going to keep an eye on it this afternoon and keep my fingers crossed that this whole nightmare has been a theme issue and that now that i have changed theme i might be OK
    cheers
    k

  15. Oleg Dudkin
    Member
    Posted 2 years ago #

    Do you still have all plugins disabled?

  16. kateh
    Member
    Posted 2 years ago #

    no - i've activated a few now.... Akismet, Google XML sitemaps, share this, social media widget, wp cache and wp text sizer... should i turn them off again?

  17. kateh
    Member
    Posted 2 years ago #

    ah - i think it just went again.... got the PHP Error message again! (though i want to check this in case it was a window i'd left open from yesterday... but i dont think so)
    How can it be alright all day and then around half one / 2 o'clock it all starts up again.....
    turning all the plugins off again now

  18. Oleg Dudkin
    Member
    Posted 2 years ago #

    Does Google XML sitemap options page show some errors?

  19. kateh
    Member
    Posted 2 years ago #

    i'll turn it back on and have a look

  20. kateh
    Member
    Posted 2 years ago #

    ah it says

    There was a problem writing your sitemap file. Make sure the file exists and is writable. Learn more
    There was a problem writing your zipped sitemap file. Make sure the file exists and is writable. Learn more
    The building process took about 0.01 seconds to complete and used 15.5 MB of memory.
    If you changed something on your server or blog, you should rebuild the sitemap manually.
    If you encounter any problems with the build process you can use the debug function to get more information.
    There is a new beta version of this plugin available which supports the new multi-site feature of WordPress as well as many other new functions! More information and download

  21. Oleg Dudkin
    Member
    Posted 2 years ago #

    There must be button somewhere to manually rebuild map. Try to use it.
    See if it causes some errors

  22. kateh
    Member
    Posted 2 years ago #

    i clicked the rebuild manually button and now it says the following - no errors!:

    Your sitemap was last built on September 6, 2011 1:22 pm.
    Your sitemap (zipped) was last built on September 6, 2011 1:22 pm.
    Google was successfully notified about changes.
    Bing was successfully notified about changes.
    Ask.com was successfully notified about changes.
    The building process took about 6.68 seconds to complete and used 17.75 MB of memory.
    If you changed something on your server or blog, you should rebuild the sitemap manually.
    If you encounter any problems with the build process you can use the debug function to get more information.
    There is a new beta version of this plugin available which supports the new multi-site feature of WordPress as well as many other new functions! More information and download

    my new problem: randomly when i click a page on the blog it shuts firefox down! off to uninstal firefox and reinstall

    thank you Oleg

  23. Oleg Dudkin
    Member
    Posted 2 years ago #

    if Firefox shuts down it could be only Firefox issue or a virus.
    Try to use IE instead - it will show you all errors.
    Turning XML sitemap plugin off fixes problem?

  24. kateh
    Member
    Posted 2 years ago #

    just updated to the latest firefox... and it still happening (this problem only started in last hour or so!)
    I'll try through IE and see how that goes
    and will turn off xml sitemap and see if that makes a difference (its the only plugin activated at the moment)

    whew! :-)

  25. kateh
    Member
    Posted 2 years ago #

    just shut down firefox again - why would it happen only when i'm clicking pages on the blog and not any other site?

    sorry to bother you with all these questions! trying to understand what is going on and how to stop iT!!!

  26. Oleg Dudkin
    Member
    Posted 2 years ago #

    my firefox is not shutting down..
    Do you have an antivirus?

  27. kateh
    Member
    Posted 2 years ago #

    doesnt happen every time .... i can be on for a wee while before it does

    hmm anti-virus: i'm on a laptop attached to work network.... but we have been having major server problems --- last week it gave up the ghost and we were offline for two days .... maybe the anti-virus stuff hasnt been reactivated yet? or there was a gap when something got it. will go and see if i can find out.....do a virus scan etc

    thank you!

  28. kateh
    Member
    Posted 2 years ago #

    anti virus software all up to date
    currently doing a virus scan but no issues so far

  29. kateh
    Member
    Posted 2 years ago #

    just cleared firefox cache and waiting to see if that fixes the closing down thing!

    crossing my fingers ... not had a PHP Fatal Error message since i changed the theme (however all plugins still switched off as well)

  30. kateh
    Member
    Posted 2 years ago #

    that didnt work - everything was a bit quicker for a while then i clicked a page and it closed firefox again

Topic Closed

This topic has been closed to new replies.

About this Topic