WordPress.org

Ready to get started?Download WordPress

Forums

PHP Fatal error: Allowed memory size! (6 posts)

  1. SUISSAC
    Member
    Posted 1 year ago #

    Hello,
    I get PHP Fatal error: Allowed memory size (Fatal error: Allowed memory size of 805306368 bytes exhausted (tried to allocate 71 bytes) in ...)
    I have set memory limit in php.ini to 768MB!

    Thank you!

  2. That setting in php.ini is far too high; all php processes will use it and you will run out of memory. Set your php.ini file back to 32M and try adding the 'define" line below in your wp-config.php file a few lines of white space below the opening <?php in the file:

    define('WP_MEMORY_LIMIT', '64M');

  3. SUISSAC
    Member
    Posted 1 year ago #

    Hello,
    I tryed that and didn`t work! :/

  4. SUISSAC
    Member
    Posted 1 year ago #

    Also i need to tell you that the website is a little bigger like (15k+ posts) and 2 cache plugins (super cache and db cache).

  5. SUISSAC
    Member
    Posted 1 year ago #

    Now i get the error on the category posts for db-cache-reloaded-fix/db-module.php on line 396 :/

  6. catacaustic
    Member
    Posted 1 year ago #

    The line that the error happens on doesn't tell you where the error actually is - all it does is tell you where your memory overflow finally gets to much for the system.

    If you have your memory limit set that high there is something very wrong with your site. You should deactivate all pluigns and switch to the default theme and check that the meomory usage is back to where it should be (I'll bet that it will be). After that re-enable the theme and plugins one-by-one and check each time to see which one makes the memory usage jump up that much.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.