WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
PHP Errors (2 posts)

  1. rrhobbs
    Member
    Posted 1 year ago #

    I have a heap of these in my php errors:

    [07-Dec-2012 22:10:54 UTC] PHP Warning: stristr() [<a href='function.stristr'>function.stristr</a>]: Empty delimiter in /home/user/public_html/subdomain/wp-content/plugins/wp-super-cache/ossdl-cdn.php on line 36

    [07-Dec-2012 17:06:55 UTC] PHP Warning: preg_match() [<a href='function.preg-match'>function.preg-match</a>]: Unknown modifier 't' in /home/user/public_html/subdomain/wp-content/plugins/wp-super-cache/ossdl-cdn.php on line 74

    WordPress is installed in the subdomain and I am using MaxCDN (generally n/p).

    After I installed WP-SuperCache my (SiteTree) xml sitemap started coming up blank after months of working fine. So I added some strings; I was using W3TC for a while (TOO much information!) and I had same intermittent problems as well as my contact form getting horked so:

    I have the following in my settings / CDN substrings exclude form: .php,.xml,sitemap,robots,

    I also have the following in my CDN include directories strings form:
    wp-content,wp-includes,archive,

    I did just remove "archive"; it is my html sitemap generated by SiteTree, residing at /archive/.

    I have the following in my settings / advanced / no-cache form:
    wp-.*\.php
    index\.php
    nyc-locationscout-us-contact-form
    .*\.xml

    Note: "nyc-locationscout-us-contact-form" was originally set as "/nyc-locationscout-us-contact-form/" it was just changed, perhaps that will stop php from crying?

    Also I am just sort of guessing at the syntax(es) being correct; any advice or correction is appreciated!

    thx

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. rrhobbs
    Member
    Posted 1 year ago #

    I am trying to get a series of buttons to serve from the cdn; the default include directive of wp-content somehow doesnt do it.

    A directory, /wp-content/header-images (contains the images served up by the random header images plugin I use on my site) is served successfully from the CDN without any modifications to the CDN include files form.

    Here is a representative url of where the problem images reside:

    http://subdomain.website.tld/wp-content/themes/weaver-ii-pro/includes/pro/social/1/facebook.png

    ???

    thx

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic