WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
PHP error on WP Super Cache fopen/fclose/fputs (12 posts)

  1. aaurel1an
    Member
    Posted 3 years ago #

    I get these strange errors and can't find what's wrong. Is there a special setting i should have?

    [Thu Nov 25 19:09:35 2010] [error] [client 89.33.6.109] PHP Warning:  fputs(): supplied argument is not a valid stream resource in /home/observator/public_html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 785, referer: http://observator.ro/stiri/stiri-live/page/17
    [Thu Nov 25 19:09:35 2010] [error] [client 89.33.6.109] PHP Warning:  fclose(): supplied argument is not a valid stream resource in /home/observator/public_html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 786, referer: http://observator.ro/stiri/stiri-live/page/17
    [Thu Nov 25 19:09:36 2010] [error] [client 89.33.6.109] PHP Warning:  fopen(/home/observator/public_html/wp-content/cache/meta/9830997974cee9850da8615.52819804.tmp) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: Permission denied in /home/observator/public_html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 784, referer: http://observator.ro/stiri/stiri-live/page/18
    [Thu Nov 25 19:09:36 2010] [error] [client 89.33.6.109] PHP Warning:  fputs(): supplied argument is not a valid stream resource in /home/observator/public_html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 785, referer: http://observator.ro/stiri/stiri-live/page/18
    [Thu Nov 25 19:09:36 2010] [error] [client 89.33.6.109] PHP Warning:  fclose(): supplied argument is not a valid stream resource in /home/observator/public_html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 786, referer: http://observator.ro/stiri/stiri-live/page/18
    [Thu Nov 25 19:09:38 2010] [error] [client 89.33.6.109] PHP Warning:  fopen(/home/observator/public_html/wp-content/cache/meta/3130374084cee9852348141.87249685.tmp) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: Permission denied in /home/observator/public_html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 784, referer: http://observator.ro/stiri/stiri-live/page/19
    [Thu Nov 25 19:09:38 2010] [error] [client 89.33.6.109] PHP Warning:  fputs(): supplied argument is not a valid stream resource in /home/observator/public_html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 785, referer: http://observator.ro/stiri/stiri-live/page/19
    [Thu Nov 25 19:09:38 2010] [error] [client 89.33.6.109] PHP Warning:  fclose(): supplied argument is not a valid stream resource in /home/observator/public_html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 786, referer: http://observator.ro/stiri/stiri-live/page/19
    [Thu Nov 25 19:09:39 2010] [error] [client 89.33.6.109] PHP Warning:  fopen(/home/observator/public_html/wp-content/cache/meta/14733148734cee985380ad29.25690697.tmp) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: Permission denied in /home/observator/public_html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 784, referer: http://observator.ro/stiri/stiri-live/page/20
    [Thu Nov 25 19:09:39 2010] [error] [client 89.33.6.109] PHP Warning:  fputs(): supplied argument is not a valid stream resource in /home/observator/public_html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 785, referer: http://observator.ro/stiri/stiri-live/page/20
    [Thu Nov 25 19:09:39 2010] [error] [client 89.33.6.109] PHP Warning:  fclose(): supplied argument is not a valid stream resource in /home/observator/public_html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 786, referer: http://observator.ro/stiri/stiri-live/page/20
    [Thu Nov 25 19:09:41 2010] [error] [client 89.33.6.109] PHP Warning:  fopen(/home/observator/public_html/wp-content/cache/meta/4419397334cee98550bb806.96692868.tmp) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: Permission denied in /home/observator/public_html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 784, referer: http://observator.ro/stiri/stiri-live/page/21
    [Thu Nov 25 19:09:41 2010] [error] [client 89.33.6.109] PHP Warning:  fputs(): supplied argument is not a valid stream resource in /home/observator/public_html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 785, referer: http://observator.ro/stiri/stiri-live/page/21
    [Thu Nov 25 19:09:41 2010] [error] [client 89.33.6.109] PHP Warning:  fclose(): supplied argument is not a valid stream resource in /home/observator/public_html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 786, referer: http://observator.ro/stiri/stiri-live/page/21

    Thank you.

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    That's weird, those lines just write the cache file meta data.

    They shouldn't happen but if you're not using legacy caching mode, then disable caching for known users on the advanced caching page. There's not much point caching for them anyway.

  3. aaurel1an
    Member
    Posted 3 years ago #

    Strange...

    Don’t cache pages for known users. (Recommended) is checked. Means that the caching for known users is disabled.

    I reupdated the status and will check.

    I'm using mod_Rewrite mode. The site is loading fine though, but i keep seeing these many errors.

    Anything else that can be? Do i need a special module or any option on webserver?
    Thank you

  4. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    I'm still not sure why you're getting this error because the directory should be there. I did figure out why that code is getting executed however and have fixed that so if you want to upgrade to the development version (from here) that should fix it. (Should update in next 15 minutes or so)

  5. delamar
    Member
    Posted 3 years ago #

    I am getting the very same problems over here. And I am already using the newest version.

    Any ideas are welcome :)

  6. rsgrone
    Member
    Posted 3 years ago #

    I am getting

    PHP Warning: [function.rename]: Access is denied. (code: 5) in C:\site-directory\wp-content\plugins\wp-super-cache\wp-cache-phase2.php on line 546

    And I am using: Stable tag: 0.9.9.8 on WP 3.0.5

  7. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    That renames one of the temporary cache files. Make sure PHP can write to the cache directory?

  8. rsgrone
    Member
    Posted 3 years ago #

    Wow this is wierd now I am getting

    [function.rename]: Access is denied. (code: 5) in C:\mysite\wp-content\plugins\wp-super-cache\wp-cache-phase2.php on line 546

    I just changed the privileges on the plugin folder to 777 and it is still throwing that error...

    Any clue?

    Truthfully, I was not having any problems with the older version, and I have not narrowed it down to whether this started after the 3.0.5 upgrade or the SP Super-Cache upgrade...

    Is there a way to "rollback' to the last release of WP-Super Cache to test?

  9. rsgrone
    Member
    Posted 3 years ago #

    P.S. I am also getting this, after tohe 3.0.5 upgrade

    PHP Deprecated: Function set_magic_quotes_runtime() is deprecated in C:\mysite\wp-settings.php on line 27

    Could they be related?

  10. rsgrone
    Member
    Posted 3 years ago #

    ah... I just noticed this is new... I am using Windows Server 2008 R2 with their url rewrite module and now, I am getting this error message onthe dashboard

    Mod rewrite may not be installed!
    It appears that mod_rewrite is not installed. Sometimes this check isn’t 100% reliable, especially if you are not using Apache. Please verify that the mod_rewrite module is loaded. It is required for serving Super Cache static files. You will still be able to use legacy or PHP modes.

    Would that be a clue?

  11. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    They're unrelated.

    Read the warning. I don't have access to a Windows server and can't test if the machine has the ability to run mod_rewrite rules. That's way the warning says, "may not be".

  12. rsgrone
    Member
    Posted 3 years ago #

    Ah -- regarding the "testing" I could provide you with access to one of the many sites I have, or... what type of testing would you require and I could give it a try for you...

    I switched to the php option... I do not really understand the purpose of using php. Does that mean php will be used to dish-out a static page from cache? The web page tests I have been runing from a third party site indicate to me that static caching is not functioning although, I can see the static pages being created...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic