WordPress.org

Ready to get started?Download WordPress

Forums

SSH SFTP Updater Support
[resolved] PHP error: Maximum execution time (6 posts)

  1. kanabiscz
    Member
    Posted 11 months ago #

    Hi,
    Is not working! Guess I did something wrong.

    [Mon Sep 09 18:23:54.719673 2013] [:error] [pid 5755] [client 78.108.103.84:63051] PHP Fatal error: Maximum execution time of 30 seconds exceeded in /home/kanabys/kamenixtan/wp-content/plugins/ssh-sftp-updater-support/phpseclib/Math/BigInteger.php on line 1653, referer: http://kamenitxan.eu/wp-admin/network/update.php?action=install-plugin&plugin=bulk-delete&_wpnonce=1b8d77010d

    I can send you debug info from plugin. Are some private information in it or can I post i here?

    Thanks for your help

    http://wordpress.org/plugins/ssh-sftp-updater-support/

  2. TerraFrost
    Member
    Plugin Author

    Posted 11 months ago #

    I can send you debug info from plugin. Are some private information in it or can I post i here?

    You mean the SSH logs or what?

    I guess you can email terrafrost@php.net to be on the safe side.

    That said, here's the line number where it's stalling out on:

    $temp->value = bcpowmod($this->value, $e->value, $n->value, 0);

    Does it always stall out on that line number / file?

  3. TerraFrost
    Member
    Plugin Author

    Posted 11 months ago #

    Your server host key is huge :O

    The exponent is 0x10001 or 65537. That's pretty standard.

    The modulo otoh... it's 0x400 bytes long or 1024 bytes or 8096 bits. That's huge.

    Mine, in contrast, has an exponent of 0x25 or 37. Common for OpenSSH. The modulo length is 0x80 or 128 bytes or 1024 bits. Pretty standard.

    Anyway that said, using the latest Git version of phpseclib might help you. In the ssh-sftp-updater-support directory there should be a phpseclib directory. If you could replace that directory with the phpseclib-master\phpseclib directory in this file:

    https://github.com/phpseclib/phpseclib/archive/master.zip

    What the latest Git version does - that the WordPress version doesn't do - is that it'll use OpenSSL, if it's available, for modular exponentiation. This results in a pretty dramatic speedup as documented here:

    http://phpseclib.sourceforge.net/math/intro.html

    ie. for a 2048-bit key it takes 4.5 seconds with BCMath without OpenSSL and 0.5 seconds with OpenSSL. At least on PHP 5.3. On PHP 5.4 the speedup is even more dramatic.

  4. kanabiscz
    Member
    Posted 11 months ago #

    phpseclib didnt help. Still same issue.

    And I have PHP 5.5. Also I can ask my server admin for more logs(SSH or others?) if you want.

  5. TerraFrost
    Member
    Plugin Author

    Posted 11 months ago #

    Your server host key is huge :O

    Actually, I was wrong - your server host key is fine. It's the public key you're using to login with. It's huge.

    Anyway, your options are three fold. Install gmp, install openssl or make use of a smaller RSA key.

    And I have PHP 5.5. Also I can ask my server admin for more logs(SSH or others?) if you want.

    Not going to help. The issue is pretty clear (it's as described above).

  6. kanabiscz
    Member
    Posted 11 months ago #

    I created new SSH key with length 2048 and it works great!

    Thanks for your help.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.