WordPress.org

Ready to get started?Download WordPress

Forums

php error in new install (1 post)

  1. trondertn00b
    Member
    Posted 7 years ago #

    Hi.

    I use WP2.0 to host a blogg on Gentoo. And i just made another blogg, on my same private server. Followed the installation. The blog works fine, but now i have installed the widgets plugin and activated it. When i now go and move a widget into my sidebar, and then hit the "edit" button, to enter text in a text widget(or any other widget). I get this error in the edit window that pops up:

    Code:
    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, '' was given in /home/hula/public_html/wp-content/plugins/widgets/widgets.php on line 645

    Dident get this on on my other blogg, so kinda confused now.

    plugins/widgets/widgets.php

    Code:
    <div id="controls">
    <?php foreach ( $registered_widget_controls as $name => $widget ) : ?>
    <div class="hidden" id="<?php echo $widget['id']; ?>control">
    <span class="controlhandle"><?php echo $name; ?></span>
    <span id="<?php echo $widget['id']; ?>closer" class="co$
    <div class="controlform">
    <?php call_user_func_array($control['callback'], $control['params']); ?>
    </div>
    </div>
    <?php endforeach; ?>
    </div>

    the "php foreach" is line 645

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags