WordPress.org

Ready to get started?Download WordPress

Forums

JSON REST API (WP API)
[resolved] php 5.3.x DateTime::createFromFormat() (4 posts)

  1. dunar21
    Member
    Posted 7 months ago #

    This call in lib/class-wp-json-posts.php (and probably elsewhere) does not seem to always work with php versions < 5.4 (despite the php docs). Yes people can probably use latest versions with their shared hosting if they know how or know how/where to look, but for those who do not will probably get pretty frustrated. Hostgator's default is 5.3. You can use 5.4 by adding:
    AddType application/x-httpd-php54 .php
    to your .htaccess file in the root of your file structure.

    It would be good if you either chose another method to use for this or checked if the mehod is available and if not, then use a different one for compatability issues that may occur.

    http://wordpress.org/plugins/json-rest-api/

  2. Ryan McCue
    Member
    Plugin Author

    Posted 7 months ago #

    Filed as issue #52. Thanks!

  3. Ryan McCue
    Member
    Plugin Author

    Posted 4 months ago #

    This has now been fixed and will be included in the next release, marking as resolved.

  4. dunar21
    Member
    Posted 4 months ago #

    Thanks

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.