WordPress.org

Ready to get started?Download WordPress

Forums

php 4.1? (6 posts)

  1. bujai
    Member
    Posted 9 years ago #

    I want to upgrade to 1.5 from 1.2,but my host run php,how i do?

    "Your server is running PHP version but WordPress requires at least 4.1"

  2. eridan
    Member
    Posted 9 years ago #

    Tell your host to uprade to the latest php version.

  3. rwatkins
    Member
    Posted 9 years ago #

    Hey,

    Are you on a commercial webhost? If so, send them an email and ask them to upgrade to (at least) php 4.1 - the current latest version (of 4) is 4.3.11.

    If you are hosting it yourself (off your own computer) then you need to upgrade it yourself. Shout back if you are in this situation.

    Rob

  4. bujai
    Member
    Posted 9 years ago #

    thank you very much!

    I just called my webhost provider , they telled me the host 's php version is 4.2, but why:

    Warning: phpversion,system() has been disabled for security reasons in /z2/bujai/public_html/blog/wp-settings.php on line 16

    Warning: phpversion,system() has been disabled for security reasons in /z2/bujai/public_html/blog/wp-settings.php on line 17
    Your server is running PHP version but WordPress requires at least 4.1

  5. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Who is your host ?
    To disable that call seems ridiculous. I would find another host.

  6. rwatkins
    Member
    Posted 9 years ago #

    Hey,

    That is really stupid, yeah.

    Really awful hack: Try commenting out (add a // to the start of each line) lines 16 and 17 of wp-settings.php (where it says if ( !(phpversion().. and the line beneath) and then continue as normal.

    This will make the error go away, but I'm unsure as to whether your host is still to restrictive to allow WordPress to run normally.

    Rob

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.