WordPress.org

Ready to get started?Download WordPress

Forums

Photos not uploading properly to media gallery (8 posts)

  1. icelandicody
    Member
    Posted 4 years ago #

    Whether I upload the image via the individual post or via the 'add new media' option, the images aren't uploading properly. They seem to upload fine, but just show up as a blue question mark.
    For example, http://www.shopeponymy.com/wp-content/uploads/2010/01/mifflinjewelrytrunkshow.jpg. If you try to follow the link, you get the 404 message.
    I have made sure there is a wp-content/uploads/2010/01 folder in my public_html folder and the permission has been set to 755.
    All of the images I have uploaded before the issue started (several weeks ago) appear as normal on the site; I just can't get any new ones to show up.
    What am I missing?

  2. esmi
    Theme Diva & Forum Moderator
    Posted 4 years ago #

    Check the settings in Admin/Settings/Miscellaneous. The Store uploads in this folder should be set to wp-content/uploads and Organize my uploads into month- and year-based folders should be ticked.

  3. icelandicody
    Member
    Posted 4 years ago #

    Thank you! Don't know how that got unchecked... Problem solved. Phew.

  4. esmi
    Theme Diva & Forum Moderator
    Posted 4 years ago #

    Double-check any images that you recently uploaded and/or added to posts. It's possible that you might need to re-upload some of them.

  5. betaphi
    Member
    Posted 3 years ago #

    I've uploaded photos for five years with no problems. Now when I try to upload a photo, I get "nameofphoto.jpg" instead of the actual photo. The same thing shows up under code. Can you help me?

  6. esmi
    Theme Diva & Forum Moderator
    Posted 3 years ago #

    Have you checked to see if you've used all of the available space in your hosting account?

  7. betaphi
    Member
    Posted 3 years ago #

    Sorry, esmi, not sure what you're referring to. Can you say more? My blog is effectively shut down without the ability to upload photos.

  8. esmi
    Theme Diva & Forum Moderator
    Posted 3 years ago #

    Contact your hosts and ask if you've used up all of your web space.

Topic Closed

This topic has been closed to new replies.

About this Topic